The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nameserver setting drive me crazy

Discussion in 'Bind / DNS / Nameserver Issues' started by crliuh, Jun 17, 2014.

  1. crliuh

    crliuh Member

    Joined:
    Jun 16, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi,

    recently i just setup my whm in aws micro instance (my first time to set up server). all the installation and setting was fine except for setting up the nameserver. i've few questions,

    1. can i use one ip for two nameservers? In my whm only appears with one ip. when adding new nameserver in nameserver registration im using the following values,

    ns1.example.com
    54.255.196.150
    ns2.example.com
    54.255.196.150

    both same ip.

    2. in my whm's NS record report, there is no ip resolved for both domain name.
    Nameserver Resolved IP Zones Actions
    ns1.example.com No IP 7 Edit
    ns2.example.com No IP 7 Edit


    3. im not able to ping my nameserver. ns1.example.com

    please help. when im trying to change my .org domain NS pointing to ns1.example.com. it won't resolve, whereas no problem for .com domain to resolve.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Yes, it's acceptable to use the same IP address for multiple name servers. The "NS record report" page is not relevant to the propagation or configuration of your name servers. It's just listing which zones use which name servers. Make sure the "A" record for your NS entries are added in the DNS zone of the domain name they are associated with, and that the domain name points to your server from the registrar.

    Thank you.
     
  3. crliuh

    crliuh Member

    Joined:
    Jun 16, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Thanks micheal!

    i got this weird situation whereby all the .com domain looks fine in the DNS health check but the rest of the TLD doesn't look fine.

    http://www.intodns.com/jaycar.my
    this stated something wrong with my NS A record

    http://www.intodns.com/ascotville.com
    this looks fine

    both hosted under my whm and both of them have the same setting in WHM's DNS zone

    ascotville dns zone.png jaycar dns zone.png
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please check with the domain registrar for the .my domain name. It looks like the name servers configured at the registrar are not reporting correctly.

    Thank you.
     
  5. crliuh

    crliuh Member

    Joined:
    Jun 16, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    below is the jaycar.my nameserver setting,

    Primary Name Server Hostname : ns1.eatplayfun.com
    Primary Name Server Netaddress : 54.255.196.150

    Secondary Name Server Hostname : ns2.eatplayfun.com
    Secondary Name Server Netaddress : 54.255.196.151

    is exactly the same as what i have done for .com domain.

    i've another .org domain is facing the same issue as .my domain too http://www.intodns.com/cancer-irca.org

    i just received another email from my cpanel stated that there is error in my imap and nameserver,

    FAILED  imap on vps1.eatplayfun.com  172.31.5.255.png FAILED  nameserver on vps1.eatplayfun.com  172.31.5.255.png
     

    Attached Files:

  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you verify if the issue has been resolved? I see both of those domain names are now resolving well and reporting as such through "dig" and websites such as IntoDNS.

    Thank you.
     
  7. crliuh

    crliuh Member

    Joined:
    Jun 16, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Thanks micheal. It's resolved. The issue happened because the domain was not resolved completely. Thanks alot!

    - - - Updated - - -

    One more question, what about the email issue that i just mentioned?
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  9. crliuh

    crliuh Member

    Joined:
    Jun 16, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Sure. And thanks again!
     
  10. Harlequin

    Harlequin Member

    Joined:
    Sep 4, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Santa Cruz de Tenerife, Spain
    cPanel Access Level:
    Reseller Owner


    I have the same issue:


    7cIp7Ef[1].png

    And need to know how to change this.
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please see my earlier response on this thread:

    Thank you.
     
Loading...

Share This Page