The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nameserver setup hanging

Discussion in 'Bind / DNS / Nameserver Issues' started by cloud9it, Jul 14, 2012.

  1. cloud9it

    cloud9it Registered

    Joined:
    Jul 14, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Is anyone else seeing the setup hanging at step 4 on CentOS 6.3 as seen here:
    http://o7.no/wCOFdx
     
    #1 cloud9it, Jul 14, 2012
    Last edited: Jul 14, 2012
  2. iakela

    iakela Member

    Joined:
    Oct 18, 2009
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Did you check the installations logs?
    /var/log/cpanel-install-thread0.log
     
  3. cloud9it

    cloud9it Registered

    Joined:
    Jul 14, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Turns out it's a known issue with CentOS 6.3. If you run these commands, everything works.

    > $ mv /etc/init.d/named /etc/init.d/named.bak
    > $ yum reinstall bind
    > $ cd /etc/init.d/
    > $ grep port named
    (looking for this output)
    > export KRB5_KTNAME=${KEYTAB_FILE:-/etc/named.keytab}
    > [ -x /sbin/portrelease ] && /sbin/portrelease named &>/dev/null || :

    Then type:
    > $ /etc/init.d/named stop; /etc/init.d/portreserve restart; /etc/init.d/named start; netstat -plan | grep 953 | grep named
    And you should see this:
    > Stopping named: . [ OK ]
    > Stopping portreserve: [ OK ]
    > Starting portreserve: [ OK ]
    > Starting named: [ OK ]
    > tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 15277/named
     
Loading...

Share This Page