The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Nameserver setup] I'm having problems

Discussion in 'Bind / DNS / Nameserver Issues' started by Xandrios, Apr 28, 2004.

  1. Xandrios

    Xandrios Registered

    Joined:
    Apr 28, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    Ive installed Cpanel on Redhat 9 just a few days ago, and i'm having problems regarding DNS / Nameservers.

    First let me draw a scetch of the situation:
    I'm running the latest Cpanel on a Redhat9 box, whitch is behind a NAT router. In order to get it to work (The box is for testing purposes), I had to 'portmap' a list of ports. That did work, because the licence requests come through, and people can login using SSH. (From an outside IP).
    But the IP of my server is still '192.168.0.100', so, no public IP.

    The problem i'm having is the following: I get an error when I try to setup a new account:
    So I tried setting up the nameserver values. I have got two IP's from my ISP (217.19.16.131 & 213.239.128.5). Those should be able to do a DNS lookup.
    I added those IP's in the "Resolver Configuration", but that didn't fix the problem. Then I tried "manage Nameserver IP's". I added a DNS IP, didn't work either.
    When I try to setup a value in the "Server setup > edit settings > Primary Nameserver", using 'Add an A entry for this nameserver', it gives the following error: "Cannot determine ip for ns1.xandrios.net".
    ns1.xandrios.net has an A record to my (outside, public) IP.

    Ive tried filling in all values, testing, nothing seems to work.
    Anyone knows what i'm doing wrong?

    My basic goal is this:
    Setup the server in a way that i can point domain names (using an external nameserver, ie zoneedit.org) to the server, and add users who are then able to setup apache vhosts on those Domains.

    Thank you,
    Xandrios
     

Share This Page