The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nameservers / DNS / Ips

Discussion in 'Bind / DNS / Nameserver Issues' started by ehuk, Apr 10, 2008.

  1. ehuk

    ehuk Member

    Joined:
    Apr 10, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hi Guys,
    I have just installed WHM/cPanel for the first time but I am have a few problems setting up the nameservers, I have 5 IP addresses for the server with one NIC and 4 virtual devices (eth0, eth0:0, eth0:1, eth0:2, eth0:3)

    I also have 1:1 NAT, so each external IP has an internal one. Now I have my setup like this:

    NS1 - 10.0.0.1 (xx.xx.xx.24) eth0
    NS2 - 10.0.0.2 (xx.xx.xx.25) eth0:0
    Shared IP - 10.0.0.3 (xx.xx.xx.26) eth0:1

    + 2 more I will use for SSL/Dedicated IPs

    When I am at basic cPanel/WHM Config, and click on Assign IP Address for the nameservers, the internal IP (10.xx) are assigned, however when I click on add A records for this nameserver, I get:

    Found your nameserver to be: ns1.xx.com
    Found your domain name to be: xx.com
    Found your nameserver name to be: ns1
    Found your nameserver ip to be: xx.xx.xx.27
    If this looks correct,

    the .27 IP is for a website with a dedicated IP!

    I am missing something!

    Thanks in advance for your help, this is all new to me!
     
Loading...

Share This Page