dstana

Well-Known Member
Jul 6, 2016
108
19
68
Phoenix, AZ
cPanel Access Level
Root Administrator
I have a new instance I'm launching on AWS and can't get WHM to pickup the NAT. I've tried with the cPanel AMI and installing from scratch on a fresh system. I have an elastic IP attached to the instance. NAT was picked up just fine on the DNS ONLY servers I launched today to use with this instance.

I have manually added /etc/cpsources.conf with the included line mentioned in the docs.

Running /scripts/build_cpnat returns:

Code:
warn [build_cpnat] Unable to map 172.xxx.xxx.xxx
die [build_cpnat] No publicly routable addresses found.
exit level [die] [pid=1556] (No publicly routable addresses found.)
What do I do to get WHM to pick this up?
 

dstana

Well-Known Member
Jul 6, 2016
108
19
68
Phoenix, AZ
cPanel Access Level
Root Administrator
To add to this, WHM is seeing the NAT on some level. After running
Code:
/scripts/build_cpnat
/var/cpanel/cpnat does exist and has the private and public ip's in that file.

However, trying publicIP:2087 returns unreachable. I'm not sure what else goes into configuring the NAT but something is missing if the build script is throwing that error.
 
Last edited:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,273
1,282
313
Houston

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,273
1,282
313
Houston
Hi @dstana

By referencing Step 1 are you referencing this?

Code:
Open the /etc/cpsources.conf file with a text editor and add the following line:

MYIP=http://myip.cpanel.net/v1.0/
If so this portion of the documentation is option as indicated by the line above:
The /usr/local/cpanel/scripts/build_cpnat script uses the http://myip.cpanel.net/v1.0/ server to map local IP addresses to public IP addresses. However, if you wish to use a different IP address lookup service, perform the following steps: