The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ncftp

Discussion in 'General Discussion' started by gunmuse, Nov 10, 2004.

  1. gunmuse

    gunmuse Well-Known Member

    Joined:
    Jul 3, 2003
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    New Mexico
    My last box had this same problem. Cpanel wants to use ncftp and its not on the default install so some of the installations fail.

    How do I install ncftp?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Fairly straightforward:

    Code:
    wget ftp://ftp.ncftp.com/ncftp/ncftp-3.1.8-src.tar.gz
    tar -xzf ncftp-*
    cd ncftp-*
    ./configure
    make
    make install
    cd ..
    /bin/rm -Rf ncftp-*
     
  3. Vatoloco

    Vatoloco Well-Known Member

    Joined:
    Jun 21, 2004
    Messages:
    100
    Likes Received:
    0
    Trophy Points:
    16
    Sorry for bumping an old post but I was getting this error message everytime /scripts/upcp ran:

    The following packages you requested were not found:
    ncftp


    Searched these forums and found your post. It worked perfect! Thanks!

    To anyone else that needs to install ncftp the only thing that's changed in the code chirpy posted above is the version number so the first line just needs to be changed to this:

    wget ftp://ftp.ncftp.com/ncftp/ncftp-3.1.9-src.tar.gz
     
  4. flash7

    flash7 Well-Known Member

    Joined:
    Feb 16, 2004
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    Why Cpanel wants to use ncftp ?
    For what ?
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    IIRC, it doesn't, it's CPAN that uses it as a fallback for LWP when updating perl modules.
     
  6. claven177

    claven177 Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Taipei
    I use ncftp for serveral years.
    but when I connected to special Pure-FTPd host, I got Connection timed out message.
    Even I can connect to this server, I just only upload files under 5~10 MB and then remote host closed control connection.

    What's going on?


    Thanks!


    Code:
    # ncftp
    NcFTP 3.1.9 (Mar 24, 2005) by Mike Gleason (http://www.NcFTP.com/contact/).
    ncftp> open -uyyyy -pxxxxxx 64.202.111.152
    Could not connect to 64.202.111.152 -- try again later: Connection timed out.
    Could not connect to 64.202.111.152 -- try again later: Connection timed out.
    Could not connect to 64.202.111.152 -- try again later: Connection timed out.
    Could not connect to 64.202.111.152 -- try again later: Connection timed out.
    Could not connect to 64.202.111.152 -- try again later: Connection timed out.
    Could not connect to 64.202.111.152 -- try again later: Connection timed out.
    Redialing (try 6)...
    --------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    You are user number 14 of 50 allowed.
    Local time is now 15:19. Server port: 21.
    This is a private system - No anonymous login
    You will be disconnected after 3 minutes of inactivity.
    Logging in...
    User yyyy has group access to:  513
    OK. Current directory is /
    Logged in to 64.202.111.152.
    ncftp / > ls -l
    Data connection timed out.
    Falling back to PORT instead of PASV mode.
    Could not read reply from control connection -- timed out.
    List failed.
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That suggests that PASV mode isn't working on the server that you're connecting to. Try setting it in PORT mode before trying to initiate any commands.
     

Share This Page