The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ndc: connect: connection refused

Discussion in 'General Discussion' started by totalufo, Jan 17, 2002.

  1. totalufo

    totalufo Well-Known Member

    Joined:
    Jan 17, 2002
    Messages:
    160
    Likes Received:
    0
    Trophy Points:
    16
    I get this error message when trying to upadate a DNS zone. Any ideas?
     
  2. Kiwi

    Kiwi Well-Known Member

    Joined:
    Aug 11, 2001
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    RUn the following commands:

    ndc reload
    tail /var/log/messages

    This should tell you where the error is :)
     
  3. fh

    fh Registered

    Joined:
    Sep 24, 2001
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    NDC

    Check teh rndckeys are the same in named.conf and rndc.conf. Then ./ndc stop ./ndc start
     
  4. fh

    fh Registered

    Joined:
    Sep 24, 2001
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    NDC

    Check the rndckeys are the same in named.conf and rndc.conf. Then ./ndc stop ./ndc start
     
  5. hedgehog

    hedgehog Well-Known Member

    Joined:
    Nov 3, 2001
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Just run

    /scripts/fixndc

    That should get your problem solved fast and easy in most cases.

    Hedgy
     
  6. tadruj

    tadruj Member

    Joined:
    Jan 14, 2002
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    The thinginnabob is that You have bind 9.x but WHM wants 8.x, so You have to prevent /scripts/rpmup to update to hte new bind and You have to downgrade bind to 8.x

    That\'s what I\'ve done, I\'m not the WHM expert so... :P
     
  7. totalufo

    totalufo Well-Known Member

    Joined:
    Jan 17, 2002
    Messages:
    160
    Likes Received:
    0
    Trophy Points:
    16
    Here is what I get in the var/log/mesages

    Feb 5 23:32:12 localhost named[13431]: starting BIND 9.1.0 -u named
    Feb 5 23:32:12 localhost named[13431]: using 2 CPUs
    Feb 5 23:32:12 localhost named[13433]: loading configuration from \'/etc/named.conf\'
    Feb 5 23:32:12 localhost named[13433]: /etc/named.conf:54: parse error near \'ns1.maxxxhosting.com\'
    Feb 5 23:32:12 localhost named[13433]: loading configuration: failure
    Feb 5 23:32:12 localhost named[13433]: exiting (due to fatal error)
    Feb 5 23:32:12 localhost named: named startup succeeded

    I have 2 servers and I\'m trying to use my main server\'s DNS if that helps in troubleshooting this.
     
  8. AlaskanWolf

    AlaskanWolf Well-Known Member

    Joined:
    Aug 11, 2001
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Fremont CA
    anyone else got a fix on this? i ran both scripts in /scripts and neither work.....
     
  9. AmityHosting

    AmityHosting Member

    Joined:
    Oct 23, 2001
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    same error

    mine is becuase of this according to the tail /var/log/messages

    Feb 8 10:35:04 localhost proftpd[14953]: localhost.localdomain (127.0.0.1[127.0.0.1]) - FTP login timed out, disconnected.

    The script to fix it did not work, said it was already fixed, would like any ideas on this also :)
     
  10. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    As mentioned- it's true that in most of these new machines WHManager is still looking for bind 9+.....
    A downgrade to bind 8.2.3 and then a lock on the named binary will keep things stable and working with cpanel/whm until everything is in sync with bind 9.1.0, or whatever the current cpanel-installed version is.

    /scripts/fixndc and those peeps work sometimes, don't get me wrong, but I don't have a rhyme or reason or technical pattern to follow yet. When it doubt downgrade for the time being, to get things working.
     
  11. bdraco

    bdraco Guest

    Open your named.conf and fix the error on line 54

    Feb 5 23:32:12 localhost named[13433]: loading configuration from '/etc/named.conf'
    Feb 5 23:32:12 localhost named[13433]: /etc/named.conf:54: parse error near 'ns1.maxxxhosting.com'
    Feb 5 23:32:12 localhost named[13433]: loading configuration: failure


    named-checkconf is your friend
     
  12. AmityHosting

    AmityHosting Member

    Joined:
    Oct 23, 2001
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    hi

    root@localhost [/usr/sbin]# ./named-checkconf
    the default for the 'auth-nxdomain' option is now 'no'
    root@localhost [/usr/sbin]#

    but

    root@localhost [/usr/sbin]# ./ndc start
    ndc: connect: connection refused
    root@localhost [/usr/sbin]#

    still no luck for me :/
     
  13. bdraco

    bdraco Guest

    [quote:8e9280a85b][i:8e9280a85b]Originally posted by AmityHosting[/i:8e9280a85b]

    root@localhost [/usr/sbin]# ./named-checkconf
    the default for the 'auth-nxdomain' option is now 'no'
    root@localhost [/usr/sbin]#

    but

    root@localhost [/usr/sbin]# ./ndc start
    ndc: connect: connection refused
    root@localhost [/usr/sbin]#

    still no luck for me :/[/quote:8e9280a85b]

    Restart named in WHM
     
  14. AmityHosting

    AmityHosting Member

    Joined:
    Oct 23, 2001
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Attempting to restart bind
    rndc: connect: connection refused

    bind status
    bind did not return a status report


    bind started ok


    That connection refused thing comes up again :/
     
  15. awsol

    awsol cPanel Test Bitch

    Joined:
    Feb 8, 2002
    Messages:
    591
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Boston MA
    Make sure the keys are right in both named files. I had a problem with this a few times on my server.
     
  16. AmityHosting

    AmityHosting Member

    Joined:
    Oct 23, 2001
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    there exactly the same :/
     
  17. maxhost

    maxhost Well-Known Member

    Joined:
    Jan 30, 2002
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    what server do you have ?

    could be the following works (for me on a Redhat 6.2 server)
    /usr/sbin/ndc reload

    Bu it does not work on a 7.1 Redhat...

    If it is a 7.1 (or 7.2) try this:
    /etc/rc.d/init.d/named reload
    or:
    /etc/rc.d/init.d/named restart



    Sometime when i reebot a server (7.1) bind does not start and i do this manually...
     
  18. bdraco

    bdraco Guest

    [quote:a0864513e5][i:a0864513e5]Originally posted by maxhost[/i:a0864513e5]

    what server do you have ?

    could be the following works (for me on a Redhat 6.2 server)
    /usr/sbin/ndc reload

    Bu it does not work on a 7.1 Redhat...

    If it is a 7.1 (or 7.2) try this:
    /etc/rc.d/init.d/named reload
    or:
    /etc/rc.d/init.d/named restart



    Sometime when i reebot a server (7.1) bind does not start and i do this manually...[/quote:a0864513e5]


    http://web.cpanel.net/bind/

    New bind rpms for 7.1

    You'll have to install with

    rpm --nodeps bind*.rpm
     
Loading...

Share This Page