Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

ndc: error: ctl_client: evConnect(fd 3):

Discussion in 'General Discussion' started by jayglate, Sep 1, 2001.

  1. jayglate

    jayglate Active Member

    Joined:
    Aug 13, 2001
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    301
    ndc: error: ctl_client: evConnect(fd 3): Connection refused ndc: error: cannot connect to command channel (/var/run/ndc)

    How do we fix

    I ran /scrips/fixndc
    did what it said,. still no go.
     
  2. Brownie

    Brownie Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    316
    Well, at least I know we arent alone now ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Kiwi

    Kiwi Well-Known Member

    Joined:
    Aug 11, 2001
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    306
    ndc: error: ctl_client: evConnect(fd 3): Connection refused ndc: error: cannot connect to command channel (/var/run/ndc)

    Same here :P:eek::(
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. bdraco

    bdraco Guest

    Where are you getting this error.. please make sure its a 7.1 machine.
     
  5. 2mhost.com

    2mhost.com Active Member

    Joined:
    Sep 4, 2001
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    306
    i get this error when i try to restart bind .. i use Linux 6.2 from interserver.net
     
  6. DanielP

    DanielP Registered

    Joined:
    Aug 12, 2001
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    301
    Add this to the top of your /etc/named.conf

    key \"key\" {
    algorithm hmac-md5;
    secret \"XXXXXXXXXXXXXXXXXXXXXX\";
    };

    controls {
    inet 127.0.0.1 allow { any; } keys { \"key\"; };
    };

    server 127.0.0.1
    {
    keys { \"key\"; };
    };

    In /etc/rndc.conf there will be a line similar to the secret line above

    copy the secret line from it and replace the one above, restart bind and voila it works :)
     
  7. bdraco

    bdraco Guest

    Just run /scripts/fixndc .. its updated to take care of everything now.
     
  8. totalufo

    totalufo Well-Known Member

    Joined:
    Jan 17, 2002
    Messages:
    160
    Likes Received:
    0
    Trophy Points:
    316
    How do you run that script?
     
  9. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    316
    From the shell as root I\'d imagine...
    SSH in, and with root access you can run anything from within /script

    good luck.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    316
    Same Problem Here.... /scripts/fixndc didn't work!

    We are getting the same error message, but when we run /scripts/fixndc from SSH root it says this:

    Found controls in named.conf ..
    Found key in (include) named.conf ..
    named.conf has already been fixed!

    We restart bind and we still get the following error:

    ndc: error: ctl_client: evConnect(fd 3): Connection refused ndc: error: cannot connect to command channel (/var/run/ndc)



    Here is what the top of our file looks like:

    // generated by named-bootconf.pl

    options {
    directory &/var/named&;
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    //
    // a caching only nameserver config
    //
    zone &.& IN {
    type hint;
    file &named.ca&;
    };

    zone &localhost& IN {
    type master;
    file &localhost.zone&;
    allow-update { none; };
    };


    controls {
    inet * allow { any; } keys { &rndc-key&; };
    };

    include &/etc/rndc.key&;


    ## Domains ##
    zone &yourhostserver.com& IN {
    type master;
    file &yourhostserver.com.db&;
    };

    ## Domains ##


    There is nothing in the /etc/rndc.key file.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice