Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Need help in WHM for wordpress and MySQLi.

Discussion in 'General Discussion' started by curtishogq, Jan 13, 2015.

  1. curtishogq

    curtishogq Registered

    Joined:
    Jan 13, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi guys, i have problem with wordpress and MySQLi, i cant load wordpress or MySQLi for opencart in cpanel. please help. i dont know where to find support for this. Please help :(
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,160
    Likes Received:
    370
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you enabled it in EasyApache?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. anton_latvia

    anton_latvia Well-Known Member
    PartnerNOC

    Joined:
    May 11, 2004
    Messages:
    358
    Likes Received:
    4
    Trophy Points:
    168
    Location:
    Latvia
    cPanel Access Level:
    Root Administrator
    I think you have not compiled MySQLi extension into PHP. You need to rebuild apache/php (with easyapache) and under "extended settings" select MySQLi. Also suggest that you include mbstring, mcrypt, zip, soap, PDO extensions.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. curtishogq

    curtishogq Registered

    Joined:
    Jan 13, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    hi there , I had already enabled and rebuild apache but still not working. - Removed -
     
    #4 curtishogq, Jan 13, 2015
    Last edited by a moderator: Jan 13, 2015
  5. JacobPerkins

    JacobPerkins Well-Known Member

    Joined:
    May 2, 2014
    Messages:
    619
    Likes Received:
    96
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Good morning,

    Your phpinfo.php file is showing that the file
    is loading your PHP extensions. Make sure you've added the mysqli extension in this file.
     
  6. curtishogq

    curtishogq Registered

    Joined:
    Jan 13, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    how do i add mysqli extention in that file sorry im new ><
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,623
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    You may want to simply delete or move the "/home/ishoppie/public_html/php.ini" file out of the way so that the account uses the default php.ini file found at /usr/local/lib/php.ini. EX:

    Code:
    mv /home/ishoppie/public_html/php.ini /home/ishoppie/public_html/php.ini.backup
    Otherwise, you can use a command like this to determine which entries you should add to the user's individual php.ini file:

    Code:
    grep mysqli /usr/local/lib/php.ini
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice