The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help : WHM is creating accounts with errors !

Discussion in 'General Discussion' started by sickboy, Mar 14, 2010.

  1. sickboy

    sickboy Registered

    Joined:
    Mar 14, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Its a very strange situation. Ive been creating accounts with no problem for the last few days, in my new server. But today a new client signed up and I started to get this errors.


    When i try to login into the cpanel under that account I get the following errors !

     
    #1 sickboy, Mar 14, 2010
    Last edited: Mar 14, 2010
  2. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    Please make sure that you have assigned the appropriate permission and ownership with the particular account when you have hosted a new domain.
     
  3. sickboy

    sickboy Registered

    Joined:
    Mar 14, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Sorry, but I had 4 signups yestarday and there was no problem and everything is working right for the old accounts.

    But today, a had 2 signups and both are having the same problem. It seems that is affecting only new accounts creation.

    I tried to create 10 accounts via WHMCS and always the same errors. Its not affecting only 1 account if not all new accounts.

    thewebhosting mentioned that I have to assign the appropiate permission and ownership.... HOW can I do this ?

    Thanks !
     
  4. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Do you receive the error message while creating the account OR while logging into the cPanel of the newly created accounts?

    BTW, try correcting the ownership and see if it helps:

     
  5. sickboy

    sickboy Registered

    Joined:
    Mar 14, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I recive this messages while users try to login into cpanel new accounts. I have no problems with old accounts. The problem is with new accounts only !


    IS not working !

    Please any help is really apreciated !
     
    #5 sickboy, Mar 15, 2010
    Last edited: Mar 15, 2010
  6. Al-Ra3eD.CoM

    Al-Ra3eD.CoM Member

    Joined:
    Mar 17, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    You Can See The Code in

    PHP:
    pico  +60 /usr/local/cpanel/Cpanel/NVData.pm
    I Think this Problem With Perl ...

    Can You Plz Give Me The Result Of

    PHP:
    /scripts/checkperlmodules 
    GooD Luck ^_^
     
  7. sickboy

    sickboy Registered

    Joined:
    Mar 14, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1

    The line is :
    Code:
       Storable::lock_nstore(\%NVDataCACHE, $cachefile);
    The only part were I found an error while doing /scripts/checkperlmodules was the following.

    Code:
     CPAN.pm: Going to build M/MS/MSCHWERN/ExtUtils-MakeMaker-6.56.tar.gz
    
    perl-64bit-hack: enabled
    ExtUtils::MakeMaker version 6.5 required--this is only version 6.30 at Makef        ile.PL line 15.
    BEGIN failed--compilation aborted at Makefile.PL line 15.
    No 'Makefile' created  MSCHWERN/ExtUtils-MakeMaker-6.56.tar.gz
      /scripts/cpan_sandbox/x86_64/perl Makefile.PL OTHERLDFLAGS=-L/usr/lib64 LD        FLAGS=-L/usr/lib64 EXTRALIBDIR=/usr/lib64 -- NOT OK
    Running make install
      Make had some problems, won't install
    Mail::SRS is up to date (0.31).
    Acme::Spork is up to date (0.0.8).
    Archive::Tar is up to date (1.58).
    Archive::Tar::Streamed is up to date (0.03).
    Archive::Zip is up to date (1.30).
    Encode::Guess is up to date (2.03).
    Digest::MD5 is up to date (2.36).
    Digest::SHA1 is up to date (2.12).
    MIME::Base64 is up to date (3.09).
    MIME::Lite is up to date (3.027).
    URI::URL is up to date (5.03).
    HTML::Tagset is up to date (3.20).
    HTML::Entities is up to date (3.64).
    MIME::Base64 is up to date (3.09).
    Digest::MD5 is up to date (2.36).
    URI is up to date (1.53).
    Net::FTP is up to date (2.77).
    HTML::Tagset is up to date (3.20).
    HTML::Parser is up to date (3.64).
    HTML::HeadParser is up to date (3.62).
    LWP is up to date (5.810).
    Parse::RecDescent is up to date (1.964).
    OLE::Storage_Lite is up to date (0.19).
    MIME::Base64 is up to date (3.09).
    Digest::MD5 is up to date (2.36).
    URI is up to date (1.53).
    Net::FTP is up to date (2.77).
    HTML::Tagset is up to date (3.20).
    HTML::Parser is up to date (3.64).
    HTML::HeadParser is up to date (3.62).
    LWP is up to date (5.810).
    Term::ReadKey is up to date (2.30).
    Term::ReadLine::Perl is up to date (1.0303).
    Text::Query is up to date (0.07).
    Image::Size is up to date (3.220).
    DBI is up to date (1.609).
    Safe::Hole is up to date (0.10).
    Tie::ShadowHash is up to date (0.07).
    Set::Crontab is up to date (1.02).
    IO::Scalar is up to date (2.110).
    Storable is up to date (2.21).
    Spreadsheet::ParseExcel is up to date (0.57).
    Spreadsheet::WriteExcel is up to date (2.37).
    Business::OnlinePayment::AuthorizeNet is up to date (3.21).
    Business::UPS is up to date (1.13).
    CGI is up to date (3.49).
    Class::Std::Utils is up to date (0.0.3).
    Compress::Bzip2 is up to date (2.09).
    Compress::Zlib is up to date (2.024).
    DBIx::MyParsePP is up to date (0.50).
    DBD::SQLite2 is up to date (0.33).
    Date::Parse is up to date (2.30).
    File::Tail is up to date (0.99.3).
    GD::Graph is up to date (1.44).
    GD::Text::Align is up to date (1.18).
    Memoize is up to date (1.01).
    Geo::IPfree is up to date (1.100470).
    HTML::Parser is up to date (3.64).
    HTTP::Daemon::App is up to date (0.0.9).
    IO::Socket::ByteCounter is up to date (0.0.2).
    Image::Size is up to date (3.220).
    MIME::Base64 is up to date (3.09).
    Mail::DomainKeys is up to date (1.0).
    Error is up to date (0.17016).
    NetAddr::IP is up to date (4.027).
    Net::DNS::Resolver::Programmable is up to date (v0.003).
    cPCPAN: Module (Mail::SPF) holdback (v2.007 held back to 2.007001)
    Mail::SPF is up to date (2.007_001).
    Mail::SPF::Query is up to date (1.999.1).
    Mail::DKIM is up to date (0.37).
    IP::Country is up to date (2.27).
    Graph::Easy is up to date (0.64).
    Graph::Flowchart is up to date (0.11).
    cPCPAN: Module (Mail::SpamAssassin) holdback (3.003000 held back to 3.2.4)
    Mail::SpamAssassin is up to date (3.002004).
    XML::LibXML::Common is up to date (1.70).
    URI::Escape is up to date (3.30).
    XML::LibXML is up to date (1.70).
    File::Find::Rule::Filesys::Virtual is up to date (1.22).
    File::Slurp is up to date (9999.13).
    Net::DAV::Server is up to date (1.29).
    Net::Daemon is up to date (0.43).
    Net::Daemon::SSL is up to date (1.0).
    Net::LDAP is up to date (0.40).
    Net::LDAP::Schema is up to date (0.9905).
    Net::LDAP::Server is up to date (0.42).
    GD::Graph is up to date (1.44).
    Parse::RecDescent is up to date (1.964).
    Quota is up to date (1.6.4).
    SVG::TT::Graph is up to date (0.12).
    Safe::Hole is up to date (0.10).
    Text::CSV is up to date (1.17).
    Spreadsheet::ParseExcel is up to date (0.57).
    Spreadsheet::WriteExcel is up to date (2.37).
    String::CRC32 is up to date (1.4).
    SQL::Statement is up to date (1.25).
    Tie::IxHash is up to date (1.22).
    Tie::ShadowHash is up to date (0.07).
    Tie::Watch is up to date (1.2).
    Tie::DBI is up to date (1.02).
    URI::URL is up to date (5.03).
    perlmod--Install done
    Using fast module check.....checked 121 modules in 1 second(s)
    Tested 122, 122 ok, 0 failed.
    Cpanel::FastMath: [INSTALLED=1] [VERSION=0.3]
    Crypt::PasswdMD5::XS: [INSTALLED=1] [VERSION=0.3]
    Cpanel::POSIX::Tiny: [INSTALLED=1] [VERSION=1.1]
    Cpanel::Cleanup: [INSTALLED=1] [VERSION=0.4]
    Cpanel::Class: [INSTALLED=1] [VERSION=1.0.5]
    Cpanel::TaskQueue: [INSTALLED=1] [VERSION=0.3]
    
    Any help is really apreciated ! Thanks !
     
  8. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    The very first thing I take notice to when I look at your posts is this:
    Code:
    called at /usr/lib/perl5/site_perl/[b]5.6.2[/b]/x86_64-linux
    
    It would seem to me that your Perl installation got replaced with a very old version and you might want to take a peek at /var/log/yum.log to see what is going on there around the time you started having problems.

    Here is the link to 5.8.8 that Cpanel uses as standard:
    Perl 5.8.8 Installer
     
Loading...

Share This Page