The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need quick help with antivirus.exim - It does not work.

Discussion in 'General Discussion' started by jols, Apr 1, 2006.

  1. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    I have been going from advice found in this forum, but it does not seem to work.

    Right now we are receiving a ton of bouned messages that I need to automatically filter out, so I really need to get this to work.

    Here's what I have done so far:

    pico -w /etc/antivirus.exim

    Then I add the following:

    # Exim filter

    if error_message then finish endif

    if
    $message_body contains "broadcastemailcorp.odo"
    or $message_body contains "c0m"
    or $message_body contains "C0M"
    or $message_body contains "securesite.odo"
    or $message_body contains "prestigious non-accredited"
    then
    save "/dev/null" 660
    endif


    The above has absolutely no effect.

    Is there something I need to switch on to get this to work?

    Thanks much.
     
  2. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    Okay, I just made an edit in /etc/exin.conf to change this:

    #!!# message_filter renamed system_filter
    message_body_visible = 5000

    to this:

    #!!# message_filter renamed system_filter
    system_filter = /etc/antivirus.exim
    message_body_visible = 5000


    Then I restarted exim, but still no luck.
     
Loading...

Share This Page