The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need some help... addon domains to reseller

Discussion in 'General Discussion' started by I-Web, Apr 6, 2005.

  1. I-Web

    I-Web Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    I have a client, he used to have a std web hosting account with us and put in addon domains. His sites were getting so big he decided he wanted to become a reseller...

    Ok, we backed up his files, removed the addon domain from his account and then he installed the addon domain and we put his files into the new home directory, changing the username etc.. as we went along.

    These sites are all working perfectly.

    The problem is, that his bandwidth usage for his main account (that the addons used to be on) is still counting the bandwidth for these domains usage, and there is a seperate line for the bandwidth (as expected with an individual account) too..... which shows the same amount.

    Any suggestions how to stop his bandwidth counting against his main domain? (all of the addon sites are listed as deleted but are still accruing bandwidth)

    Thanks for your help :)
     
  2. I-Web

    I-Web Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Anyone have nay suggestions?

    Is there a way i can remove the addons from the bandwidth counting on the actual account? where is this info stored?
     
  3. I-Web

    I-Web Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Ok, does anyone know where the bandwidth logs are??? so i can check the ownership etc. on them???
     
  4. ZapX.net

    ZapX.net Well-Known Member

    Joined:
    Feb 24, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Sidman, PA
    Hello,

    This is the only fix I know of, and it has worked twice.

    1. Log into SSH and su to root
    2. cd /var/cpanel/users
    3. There will be a file for each user. Using your prefered editor, edit the file named after your client. I use emacs, though it seems most use pico.
    4. You will see a few lines that say XDNS#=... and a few that say DNS#=... Comment out all XDNS#=... lines, by placing a # sign before the line, or just remove it if you like.

    I hope that helps. This seems to be a bug in CPanel.
     
Loading...

Share This Page