The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

need some help restoring a backup

Discussion in 'General Discussion' started by heyjohnboy, Apr 6, 2005.

  1. heyjohnboy

    heyjohnboy Well-Known Member

    Joined:
    Oct 7, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Valencia, CA
    A client was hacked by someone via the phpBB vulnerability. We tried to restore the MySQL database from our WHM backkup, but it did not restore the DB. Is there a trick to this, do we have the backup settings wrong, or does the backup function not work as we thought?

    We have incremental backup enabled, and sql databases set to "per account only," thinking that would save all changes on a per account basis.

    When we attempted to restore from a weekly backup, we selected the user, disabled "recreate account," "give IP address," "restore subdomain entries," and "restore mail config," and enabled "restore mysql dbs."

    The routine ran successfully, but the DB was not restored. Upon looking closely at the mysql file on the backup drive, it seems there's really nothing much there.

    This box is running RHE 3 and WHM 9.9.9 S15.

    If there is a way to restore this DB, would someone please show us how? If not, what do we need to change so that the next time we need a DB, we can extract it properly.

    Thanks in advance for your insight.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,469
    Likes Received:
    197
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Ours is set to per account and entire directory, and I have used it successfully.
     
  3. heyjohnboy

    heyjohnboy Well-Known Member

    Joined:
    Oct 7, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Valencia, CA
    Are you using "Incremental backup" or not? And did you successfully restore using the WHM restore utility, or did you grab the files manually?

    Thanks for the reply.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,469
    Likes Received:
    197
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Incremental backup, and I used the feature in WHM.

    HTH
     
  5. heyjohnboy

    heyjohnboy Well-Known Member

    Joined:
    Oct 7, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Valencia, CA
    So it must be our "per account only" setting. I'm going to change it to "per account and entire directory" and see if that makes the difference. Thanks.
     
Loading...

Share This Page