need to assign mysql root user to database with full permission

Bashed

Well-Known Member
Dec 18, 2013
146
4
68
cPanel Access Level
Root Administrator
I have a Centos 6 box with MySQL 5.6

There's a database control panel script I bought that requires full root access to MySQL. I can't figure out via CLI how to greant the mysql root user the full permissions to the database I created.

I ran this but it doesn't seem to have fixed my issue.

mysql> GRANT ALL PRIVILEGES ON * . * TO 'root'@'localhost';
Query OK, 0 rows affected (0.00 sec)

mysql> FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.01 sec)
Would appreciate help.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
Hello :)

Before proceeding, could you have them elaborate on why full root access to the MySQL server is required? Typically you create a database user, choose the privileges, and assign that particular user to the database.

Thank you.
 

Bashed

Well-Known Member
Dec 18, 2013
146
4
68
cPanel Access Level
Root Administrator
Yes, I have done that already but it's not working for me.

mysql> SHOW GRANTS FOR 'root'@'localhost';
+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| Grants for [email protected] |
+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' IDENTIFIED BY PASSWORD '*' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 2147483647 MAX_UPDATES_PER_HOUR 2147483647 MAX_CONNECTIONS_PER_HOUR 2147483647 MAX_USER_CONNECTIONS 2147483647 |
| GRANT ALL PRIVILEGES ON `dashboard`.* TO 'root'@'localhost' WITH GRANT OPTION |
| GRANT PROXY ON ''@'' TO 'root'@'localhost' WITH GRANT OPTION |
+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
3 rows in set (0.00 sec)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
New Yes, I have done that already but it's not working for me.
Could you elaborate on what in particular is not working?

Thank you.