Need to temporarily enable TLSv1

tomfra

Well-Known Member
Sep 30, 2002
68
1
158
I need to enable TLSv1 and TLSv1.1 on our server temporarily, for one of our apps that requires it still, for now. However, cPanel is no longer allowing that the "standard way". Editing the values in httpd.conf do not seem to do anything. How should I proceed?

Thanks!
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,029
313
cPanel Access Level
Root Administrator
@tomfra - editing the httpd.conf file directly on a cPanel system will never give good results, as cPanel builds that file from other configuration options on the system, so your changes will be overwritten. Using the area of WHM that @serpent_driver highlighted is the correct way to adjust the ciphers and TLS options on the machine. Can you try that and let us know if you still see issues?
 

tomfra

Well-Known Member
Sep 30, 2002
68
1
158
Thanks, will do. We have paid support that is normally quite capable, I posted on the forums because this time they were not available for a while and we had to solve the issue urgently. They are on it now so hopefully they will be able to solve it.
 
  • Like
Reactions: cPRex

vacancy

Well-Known Member
Sep 20, 2012
482
170
93
Turkey
cPanel Access Level
Root Administrator
Since v90, support for cpanel apache tls 1.0 and tls 1.1 has been removed.

When we want to activate from the Apache configuration section, we see a faulty configuration warning. We will be glad if you share the solution.

 

tomfra

Well-Known Member
Sep 30, 2002
68
1
158
Vacancy: Our support solved it for us by editing the apache conf file directly and setting it so that cpanel is unable to rewrite it. As I did not do the modification myself, I do not have all the details, however.