The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Negative Disk Usage

Discussion in 'E-mail Discussions' started by arminder, Mar 11, 2008.

  1. arminder

    arminder Registered
    PartnerNOC

    Joined:
    Apr 7, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    The disk usage for email IDs (Cpanel->Email Accounts) is showing negative values. I have tried running upcp, fixquotas and generate_maildirsize, but no luck.

    abc@def.com -33 KB 10 MB
    xyz@def.com -50 KB 5 MB

    I'm on Fedora Core 5, 11.18.3-STABLE_21703.

    Any ideas in here?
     
    #1 arminder, Mar 11, 2008
    Last edited: Mar 11, 2008
  2. Kent Brockman

    Kent Brockman Well-Known Member

    Joined:
    Jan 20, 2008
    Messages:
    1,130
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    If deleting the maildirsize file and changing the quota of these accounts does not work, you should reset these accounts. Be sure to download all the mails stored, go to your cpanel, delete these mail accounts and regenerate them. This should make it work fine again.
     
  3. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    Just a note for completeness, generate_maildirsize needs and additional flag to handle all accounts:

    "--allaccounts"

    Otherwise it will only operate on accounts where boxtrapper is enabled.
     
  4. bibin

    bibin Member

    Joined:
    Sep 10, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    incorrect quota please run :

    1- /scripts/generate_maildirsize --force --all accounts (to fix the problem)
    2- /scripts/upcp --force

    This should be a problem on servers running maildir format and not the old mbox
    format.
     
Loading...

Share This Page