Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

NeoMail not functioning?

Discussion in 'E-mail Discussion' started by Final-Solution, Sep 7, 2002.

  1. Final-Solution

    Final-Solution Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    156
    I get this message whenever I try to send a mail from any account:

    ERROR SENDING MAIL
    Sorry, there was a problem sending your message. Please click your browser's Back button, check your message, and try again.

    not too descriptive! It just started this morning or last night as I was sending mail during the day yesturday. I'm a newbie, is there any script or something that can check it out? the check mail thing in WHM didn't have a clue . . /scripts/checklink says Test Passed! Everything is up under services, any ideas what could be causing it? I can login and view mail and receive mail, just not send anything :\
     
  2. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    316
    Had the same problem with one of our server as did someone else on here. The problem turned out to be a missing symbolic link to /usr/sbin/exim for sendmail.
     
  3. Final-Solution

    Final-Solution Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    156
    How did you fix it? I'm very newbie ;x i tried /scripts/./fixeverything but it didnt fix everything :P
     
  4. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    316
    First check if it's there

    ls /usr/sbin/s*

    If it's not:
    cd /usr/sbin
    ln -s exim sendmail
     
  5. Final-Solution

    Final-Solution Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    156
    DUDE!!!!!!! You rock!!!! :)

    all fixed up.
     
  6. prudhvik

    prudhvik Member

    Joined:
    Oct 16, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    151
    Hi justink,

    Thank you so much :p
     
  7. Ajeesh

    Ajeesh Member

    Joined:
    Oct 20, 2001
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    301
    if that does not work, try:

    chmod 4755 /usr/sbin/exim
    --------

    You can check whether the mails work or not by:

    su -s /bin/bash username

    mail -v yourmail@yahoo.com
    ----

    If the mail is being sent, then there is nothing wrong with exim. If the mail is not being sent, then the error is with exim.
    It can be a sym link problem, permission problem or anything.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice