SOLVED Network error: sslv3 alert handshake failure

Operating System & Version
CloudLinux v7.9.0
cPanel & WHM Version
106.0.10

riadshout

Registered
Nov 30, 2022
3
1
3
BD
cPanel Access Level
Root Administrator
Hello everyone,
Recently i'm facing issue with yum update. I cant perfom any system update.

Here is error:

[[email protected] ~]# sudo yum update
Loaded plugins: fastestmirror, rhnplugin, universal-hooks
Network error: sslv3 alert handshake failure[[email protected] ~]# sudo yum install wget
Loaded plugins: fastestmirror, rhnplugin, universal-hooks
Network error: sslv3 alert handshake failure

[[email protected] ~]# sudo yum install telnet
Loaded plugins: fastestmirror, rhnplugin, universal-hooks
Network error: sslv3 alert handshake failure
Screenshot_26.png

Anyone please guide how to fix this problem?

Thanks
 

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
542
252
138
IN
cPanel Access Level
Root Administrator
We had a similar issue in the past where a file located at /etc/yum/pluginconf.d/rhnplugin.conf was causing the issue.

If you have the same file on your server, then edit /etc/yum/pluginconf.d/rhnplugin.conf as:

Code:
# vi /etc/yum/pluginconf.d/rhnplugin.conf

change enabled=1 to enabled=0
save the changes

# yum clean all
This resolved the issue in our case.
 
  • Like
Reactions: cPanelWilliam

riadshout

Registered
Nov 30, 2022
3
1
3
BD
cPanel Access Level
Root Administrator
We had a similar issue in the past where a file located at /etc/yum/pluginconf.d/rhnplugin.conf was causing the issue.

If you have the same file on your server, then edit /etc/yum/pluginconf.d/rhnplugin.conf as:

Code:
# vi /etc/yum/pluginconf.d/rhnplugin.conf

change enabled=1 to enabled=0
save the changes

# yum clean all
This resolved the issue in our case.


We had a similar issue in the past where a file located at /etc/yum/pluginconf.d/rhnplugin.conf was causing the issue.

If you have the same file on your server, then edit /etc/yum/pluginconf.d/rhnplugin.conf as:

Code:
# vi /etc/yum/pluginconf.d/rhnplugin.conf

change enabled=1 to enabled=0
save the changes

# yum clean all
This resolved the issue in our case.


Many thanks, The issue was already fixed, Here is more information. how the issue was fixed for me.

I found wrong Resolver Configuration: /etc/resolv.conf
Edited this configuration file:
nano /etc/resolv.conf

I put this below google dns:

nameserver 8.8.8.8
nameserver 8.8.4.4
 
  • Like
Reactions: cPanelWilliam

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
542
252
138
IN
cPanel Access Level
Root Administrator
Glad you have it resolved.