The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New Account Creation - Mail problem

Discussion in 'E-mail Discussions' started by mruncieman, Nov 4, 2004.

Thread Status:
Not open for further replies.
  1. mruncieman

    mruncieman Member

    Joined:
    Jun 18, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    We recently upgraded our WHM/cPanel to 9.9.7/9.9.8-R5 and now we are having problems when creating new accounts.

    The problem is that when a new account is created, the mail/inbox does not have the proper permissions. It has 644 instead of 660 or 664. In essence, the inbox isn't writable by mail, and therefore exim cannot deliver emails to that user.

    Is anyone else having this problem? or know of a solution?

    thanks.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That's naughty. If it's not been mentioned in the ChangeLog as being fixed, I'd suggest you log it with cPanel.

    You can fix most mail permission issues with:

    /scripts/mailperm

    Though this is of course treating the symptons rather than the disease.
     
  3. mruncieman

    mruncieman Member

    Joined:
    Jun 18, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Well, I don't know what has happened, but it appears to be working now. We were looking at the wwwacct script, and wrote in some logging statements to see if it was doing what it was supposed to, and all of a sudden the permissions on new mail accounts were set correctly. We removed the logging lines that we added, and it's still working, so I don't know what the problem was, but it seems to be fixed :confused:

    I'll let you know if it happens again though.

    Another problem we're having though deals with virtual email accounts. Whenever a virtual email user creates a new folder, the group ID isn't being set correctly.

    Here is the problem.

    UserA has UID = 1 and GID = 1 (for example)
    if UserA_1 (virtual email user) creates an email folder, the new folder has UID=1 and GID=1

    UserB has UID = 2 and GID = 3
    If UserB_1 creates an email folder, the new folder has UID = 2 and GID = 2

    It seems that the IMAP server is created the folders with GID=UID rather than determining the user's GID.

    pretty complex problem and it took us a while to figure out what it was doing, but there it is. Any suggestions?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That sounds familiar. Have you searched bugzilla for it? If it's not there and you can reproduce it, I'd suggest logging it.
     
  5. mruncieman

    mruncieman Member

    Joined:
    Jun 18, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    This looks like the problem I'm having here:

    Bug 355

    Edit:

    This one too: Bug 856
     
    #5 mruncieman, Nov 5, 2004
    Last edited: Nov 5, 2004
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  7. aingaranweb

    aingaranweb Well-Known Member

    Joined:
    Mar 23, 2003
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto, Ontario
    I have a problem with IMAP/Squirrelmail. More likely, it's a hard drive problem.

    "ERROR : Could not complete request.
    Query: CREATE "INBOX.Sent"
    Reason Given: CREATE failed: Can't create mailbox node /home2/: Permission denied"

    That's the error I'm getting. Problem is that /home2 no longer exists. The account is currently on /home. How do I go about fixing this problem?

    Thanks
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Check the login path for the account in /etc/passwd as it may be wrong. You should also check (if there is one) that it is correct in cat /home/username/etc/passwd.
     
  9. Messiah

    Messiah Member
    PartnerNOC

    Joined:
    Jul 5, 2006
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    This may well be due to a partial conversion to maildir. Run /scripts/convert2maildir as root. If you see an option for "Convert partially converted mail accounts", use it. Run /scripts/mailperm afterwards.
     
  10. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    This is an old thread (11-04-2004) so i think the poster already have the answer years ago :D
     
Loading...
Thread Status:
Not open for further replies.

Share This Page