The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New account, named hangs until restart

Discussion in 'General Discussion' started by BrooksBridges, Feb 27, 2007.

  1. BrooksBridges

    BrooksBridges Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Hey all,

    I've got 1 cpanel server that every time I add a new account to it, I have to manually restart named to get the new domain to resolve. This has been an ongoing problem, and I can't seem to chase down what's causing it. Any suggestions?

    Thanks
     
  2. psrsathish

    psrsathish Active Member

    Joined:
    Jul 19, 2006
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    India.
    Hi,

    Run /scripts/fixrndc It will fix your issue :)
     
  3. BrooksBridges

    BrooksBridges Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Yeah, I did that, and it went and changed the ownership of a whole bunch of files to named:named

    For example, some users home directories, some of the mysql databases, /usr /var and /etc

    Generally just screwed things up nice and proper. I suppose it's because I'm running named in a chroot, but I'd think cPanel would test for that and change the script accordingly


    ...


    hell, who am I kidding, they don't even act like they have a QA department, why would they care about screwing up a customer's server?
     
  4. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    any errors is /var/log/messages when you restart bind, or when creating a new domain?
     
Loading...

Share This Page