The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New accounts are created in wrong directory

Discussion in 'General Discussion' started by piotrpawlowski, May 2, 2011.

  1. piotrpawlowski

    PartnerNOC

    Joined:
    Sep 6, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    [SOLVED] New accounts are created in wrong directory

    Hello,

    Today I've faced with such problem, that new account is created on wrong partition which cause me to manualy move avvount to /home directory.
    Below is output of df -h command:

    Code:
    /dev/sda3             447G  112G  313G  27% /
    /dev/sda1             494M   38M  432M   8% /boot
    tmpfs                 1,7G     0  1,7G   0% /dev/shm
    /usr/tmpDSK           485M   23M  437M   5% /tmp
    /dev/sdc3             290G   23G  253G   9% /backup2/sd3
    /dev/sdd1             459G   84G  352G  20% /backup2/sd3/home
    /dev/sdc1             479M   38M  417M   9% /backup2/sd1
    
    New account are created in /backup2/sd3/home directory instead of home. To be sure I've checked /etc/wwwacct.conf and it looks as follow:
    Code:
    ADDR 123.456.789.123
    CONTACTEMAIL
    CONTACTPAGER
    DEFMOD rvblue
    ETHDEV eth0
    HOMEDIR /home
    HOMEMATCH home
    HOST server.example.com
    LOGSTYLE combined
    MINUID
    NS ns1.example.com
    NS2 ns2.example.com
    NS3
    NS4
    NSTTL 86400
    SCRIPTALIAS y
    TTL 14400
    
    Does anybody have an idea why such situation has place?
    Thank you in advance for any tips and suggestions.

    Regards,
    Piotr
     
    #1 piotrpawlowski, May 2, 2011
    Last edited: May 2, 2011
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Could you paste the output from the following:

    Code:
    mount
    cat /etc/fstab
     
  3. piotrpawlowski

    PartnerNOC

    Joined:
    Sep 6, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Sure thing, here it is:

    Code:
    /dev/sda3 / ext3 rw,usrquota 0 0
    proc /proc proc rw 0 0
    sysfs /sys sysfs rw 0 0
    devpts /dev/pts devpts rw,gid=5,mode=620 0 0
    /dev/sda1 /boot ext3 rw 0 0
    tmpfs /dev/shm tmpfs rw 0 0
    none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
    /usr/tmpDSK /tmp ext3 rw,noexec,nosuid,loop=/dev/loop0 0 0
    /tmp /var/tmp none rw,noexec,nosuid,bind 0 0
    sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
    /dev/sdc3 /backup2/sd3 ext3 rw 0 0
    /dev/sdd1 /backup2/sd3/home ext3 rw 0 0
    /dev/sdc1 /backup2/sd1 ext3 rw 0 0
    
    Regards,
    Piotr
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    So, /home does not have its own partition on this machine but is instead part of / partition, correct?

    Please remove this value in /etc/wwwacct.conf file:

    Code:
    HOMEMATCH home
    Change it to be blank:

    Code:
    HOMEMATCH
    Otherwise, change it to be blank in WHM > Basic cPanel & WHM Setup area.

    What it says in that area in WHM is the following:

    The fact that /backup2/sd3/home has "home" in it is causing it to match this option. Since there is more free space in that partition than in /home, it is defaulting there.
     
  5. piotrpawlowski

    PartnerNOC

    Joined:
    Sep 6, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Yes, that is corrent.


    After your suggested changes it works like a charm.
    Thank you for your support and contribution in solving my problem.

    Regards,
    Piotr
     
Loading...

Share This Page