The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

new accounts have SSH disabled by default?

Discussion in 'General Discussion' started by dreamwiz, Apr 29, 2006.

  1. dreamwiz

    dreamwiz Well-Known Member

    Joined:
    Aug 28, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    I was surprised to notice that all new accounts have SSH access disabled, though I have checked in WHM settings to have it jailshell by default to all new accounts. So now every time I create a new account, I have to go to "Manage shell access" in WHM and enable it by hand. Bug in cPanel or a "feature"?

    WHM 10.8.0 cPanel 10.8.2-C52
     
  2. vasko

    vasko Member

    Joined:
    Apr 29, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    What you did has nothing to do with the SSH access enabled to accounts. You must enable this on Package level. Make sure that your packages have SSH enabled, in this way when a new account is created it will have SSH. I assume you already have packages , so just go and use the Edit Packages link.

    If you don't have packages, i.e. you are relaying on your billing software to do that, make the changes there. Most of the billing softwares compatible with WHM / cPanel should
    have that option and do not require to have a pre-defined package for every server.

    The thing you did is much more different than this, altough it is a very nice one from security point of view.
     
  3. dreamwiz

    dreamwiz Well-Known Member

    Joined:
    Aug 28, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    Yep, Im using packages and have had the same packages for few years and always had ssh enabled there :)
     
  4. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    Did you actually check your package settings ?

    Also if your using billing software to manage your accounts make sure the settings have not changed there

    Also if the accounts are under a reseller check the reseller access rights to make sure something has not changed there

    I have seen cpanel/whm updates change some odd things in the past that it should not have changed so be sure and double check all possible settings
     
  5. Danny_T

    Danny_T Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    181
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Netherlands
    We have it too. Packages are enabled and still when a new account is created the shell access is disabled.

    It is introduced with the version bump from 10.8.1 to 10.8.2. So i guess a bug.

    Danny.
     
  6. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Bug or better security? We never automatically give shell access on all accounts. Since most users never use it, it makes more sense to enable only for users who explicitly request it.
     
  7. dreamwiz

    dreamwiz Well-Known Member

    Joined:
    Aug 28, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    Yes, I doublechecked the package settings also. Not using billingsoftware with cpanel / neither reseller.

    I think it's a bug because you can choose "enable shell access" in packages but it still disables shell access ;)

    I added this to BugZilla, you can vote here: http://bugzilla.cpanel.net/show_bug.cgi?id=4111
     
  8. PeterTable

    PeterTable Member

    Joined:
    Feb 27, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem and I can replicate it by manually enabling the SSH on the account, then verify that on the package i have Shell Acces checked on and click edit (save) at last.
    cPanel just reaplies the packages to all accoutns under that package plan and shell gets disabled on all of them!!!
     
  9. karlsson

    karlsson Registered

    Joined:
    Feb 12, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I am having this same problem. I edited my package, which included shell access, and then after that each account had shell access disabled. This is happening on FreeBSD and on WhiteBox. I just recently upgraded them both 10.8.2 and that is when the problem started.

    So, not only is this making it so that all new accounts need to be manually changed to shell access, but if you edit one of your packages at all, even if you don't change your default shell setting from on to off, if you edit one of your packages at all, all of the users who have shell access and have that package will no longer have shell access. And then you have to go redo all the changes of shells that people requested. ARG!

    Are you guys acknowledging this as a problem?

    /l
     
    #9 karlsson, May 7, 2006
    Last edited: May 7, 2006
  10. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Only if someone has submitted a bugzilla report. cPanel staff do not actively monitor the forums. http://bugzilla.cpanel.net
     
  11. PeterTable

    PeterTable Member

    Joined:
    Feb 27, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Someone recently created a bugzilla report on this. I added a few notes and a link to this forum entry for the devs to see.
    http://bugzilla.cpanel.net/show_bug.cgi?id=4111

    So no extra posts are needed unless the devs ask for it or you could add a patch on bugzilla ;)
     
Loading...

Share This Page