The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New accounts not using correct theme

Discussion in 'General Discussion' started by wmcyow, Oct 31, 2008.

  1. wmcyow

    wmcyow Member

    Joined:
    May 17, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I changed the default theme to x3 in all my packages and also in the basic cPanle/WHm setup - yet when a new account gets created the theme defaults to "x" - requiring my to manually reset the theme. How can I fix this?
     
  2. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    Which version of WHM/Cpanel are you using?
     
  3. forum17

    forum17 Active Member

    Joined:
    Mar 30, 2007
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    0
    You need to change the theme defined for the package which you are using while creating account. You can change the defined theme in the package by following these steps ssh >> vi /var/cpanel/packages/package_name ; now search for line starting with word CPMOD if you find CPMOD=x change it to CPMOD=x3 . That's it :)


    Regards,
    Angelo S.
    http://midnight-cafe.co.uk
     
  4. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    Thank you for your detailed explanation!
     
  5. wmcyow

    wmcyow Member

    Joined:
    May 17, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply - I have checked all my packages - and they do list the correct theme - x3 - but the same thing is stall happending.

    I am running WHM 11.23.2 cPanel 11.23.6-R27698



    cheers,

    Bill
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Make certain x3 is stipulated as the default them in Basic cPane/WHM Setup within WHM.
     
  7. wmcyow

    wmcyow Member

    Joined:
    May 17, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I have ensured that the default is set - yet I am still needing to manually switch the theme after the accounts are created....
     

    Attached Files:

  8. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    How are you creating accounts? Are you using the form directly within WHM or a different method?
     
Loading...

Share This Page