The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New accounts serving default "great success" page from /usr/local/apache/htdocs

Discussion in 'EasyApache' started by Araunah, Mar 31, 2009.

  1. Araunah

    Araunah Member

    Joined:
    Mar 31, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I've just started with WHM/cPanel, and to my knowledge all I need to do to add accounts is use the "Create a New Account" tool in WHM. For some reason though, all the accounts I create show the "Great Success!" page, despite there being files in the account's root directory (/home/account/public_html)

    When I use tail -f /usr/local/apache/logs/error_log and request a random file on the domain, I get this:

    script '/usr/local/apache/htdocs/index.php' not found or unable to stat
    File does not exist: /usr/local/apache/htdocs/sadfadfa

    What could be causing this? The domain is resolving to the correct IP, but apache is looking in the wrong directory for my files.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,468
    Likes Received:
    196
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Did you create a package and give that new account that package?
     
  3. Araunah

    Araunah Member

    Joined:
    Mar 31, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I was under the impression that it just gave a default set of settings if no package was specifically set, so I didn't, but just now I manually created a package with all the default settings and gave it to the account, but no change. Still the same welcome page.
     
  4. Araunah

    Araunah Member

    Joined:
    Mar 31, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    To make this even more puzzling, here's the relevant entry in httpd.conf:

    <VirtualHost 1.1.1.1:80>
    ServerName thedomain.com
    ServerAlias www. thedomain.com
    DocumentRoot /home/thedomain/public_html
    ServerAdmin webmaster@ thedomain.com
    ## User theuser # Needed for Cpanel::ApacheConf
    <IfModule mod_suphp.c>
    suPHP_UserGroup theuser theuser
    </IfModule>
    <IfModule !mod_disable_suexec.c>
    SuexecUserGroup theuser theuser
    </IfModule>
    CustomLog /usr/local/apache/domlogs/thedomain.com-bytes_log "%{%s}t %I .\n%{%s}t %O ."
    CustomLog /usr/local/apache/domlogs/thedomain.com combined
    ScriptAlias /cgi-bin/ /home/thedomain/public_html/cgi-bin/
    </VirtualHost>
     
  5. Araunah

    Araunah Member

    Joined:
    Mar 31, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Just in case I'm not the only moron here, this was the problem:

    1.1.1.1 was the default in WHM for the IP of the new account, I figured the default would work (as some kind of localhost thing) but apparently not. Changed it to one of my actual IPs, and voila :p
     

Share This Page