The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New acount get SSH while not checked

Discussion in 'General Discussion' started by The MAzTER, Jul 24, 2003.

  1. The MAzTER

    The MAzTER Well-Known Member

    Joined:
    Jul 3, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    When i add a new acount and check ssh out. Run cpanel after it login etc. I see the SSH icon. When i try ssh it work as well!!!


    wtf???


    i created the acount like 5 times and everytime it adds SSH while i didnt check it!

    bug?

    cPanel.net Support Ticket Number:
     
  2. The MAzTER

    The MAzTER Well-Known Member

    Joined:
    Jul 3, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Ok found the problem:

    - i created a user but username was to long, so hit back and make it shorter. When u do this: ssh, cgi, frontpage etc will be checked again. Didnt notice this so only changed the username and hit the submit button again.

    - because frontpage / cgi was on i deleted the acount and created a new one with same info but everything checked off.
    When i look at the acount creation i see:

    User ***** added
    Keeping Shell Access
    Copying skel files from /root


    he keeps his shell access. What means he still doesnt delete everything when you delete a acount. :mad:

    Why isnt there a good edit function for acount or a good delete function. The delete function for a acount never worked 100% good on WHM. It pissing me off a bit. Still have to login as root (ssh) and check if everything is ok.

    cPanel.net Support Ticket Number:
     
    #2 The MAzTER, Jul 24, 2003
    Last edited: Jul 24, 2003
  3. beachtrader

    beachtrader Active Member

    Joined:
    Feb 21, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Actually I have this problem on all my servers. If I uncheck the SSH box it stills give access no matter what the username is. I have to go back and disable SSH with a wasted extra step.

    cPanel.net Support Ticket Number:
     
  4. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    Not sure this maybe the problem, but in the WHM, check the Server Setup >> Tweak Setting >> then make sure the box is not checked for
    Code:
    Use jailshell as the default shell for all new accounts (linux 2.4 or later only)
     
  5. beachtrader

    beachtrader Active Member

    Joined:
    Feb 21, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the input but I have that box unchecked on all of the servers.

    cPanel.net Support Ticket Number:
     
  6. The MAzTER

    The MAzTER Well-Known Member

    Joined:
    Jul 3, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    not checked here.

    cPanel.net Support Ticket Number:
     
  7. beachtrader

    beachtrader Active Member

    Joined:
    Feb 21, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    I think this a recent bug because little over five weeks ago it didn't do this.

    cPanel.net Support Ticket Number: 16942
     
  8. mmkassem

    mmkassem Well-Known Member

    Joined:
    Oct 21, 2002
    Messages:
    390
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Egypt
    I have the same problem too.
    The Shell Access given is a normal Shell access not Jail. If JailShell in tweak settings was checked it will give him JailShell Access.
     
  9. mmkassem

    mmkassem Well-Known Member

    Joined:
    Oct 21, 2002
    Messages:
    390
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Egypt
    This is a true bug ..

    It seems that it's here since Jail Shell was added to Cpanel.

    cPanel.net Support Ticket Number: 19382
     
Loading...

Share This Page