Joe Goldman

Member
Oct 18, 2011
7
0
51
Coffs Harbour, New South Wales, Australia
cPanel Access Level
DataCenter Provider
Hi All,

I'm trying to use the new backup system in 11.42, with an SFTP remote destination that has been verified.

When kicking off a backup - it never backs up the accounts.

If I have set 'System dir backups' to enabled, logs look like this:

Code:
[email protected]# cat /usr/local/cpanel/logs/cpbackup/1395275239.log
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from member names
/bin/gtar: /var/cpanel/dnsadmin/sock: socket ignored
/bin/gtar: Removing leading `/' from hard link targets
/bin/gtar: /var/cpanel: file changed as we read it
[backup] Failed to perform full backup of /var/cpanel/ to /backup/2014-03-20/system/dirs/_var_cpanel.tar.gz
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from member names
/bin/gtar: Removing leading `/' from hard link targets
[backup] System backups will not be uploaded to any remote destinations
Notification => <hidden> via EMAIL [level => 1]
Notification => <hidden> via PAGER [level => 1]
Looking in the /backup/2014-03-20 dir there is some system tar.gz files in there but not all of them, and it does not do the accounts.

If i set to no System Directories, so it just does the accounts, then the logs only show (straight away) the Notification => lines at the bottom of the above log.

Are these known problems? Or should the backup be working?

Thanks.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

The following message is normal when using a remote destination:

[backup] System backups will not be uploaded to any remote destinations
Information on how to enable system backups for remote destinations is available here:

How to configure system backups to a remote destination

As for the accounts, please browse to "WHM Home » Backup » Backup User Selection" and make sure backups are enabled for each user.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
I am happy to see backups are now working as expected. Thanks for updating us with the outcome.