New backup ( non legacy ) blocks my local nas

Skin

Well-Known Member
Feb 3, 2006
93
4
158
Italy
Hello,
I'm trying to use my local nas as additional destination for cpanel backup ( WHM 11.38.1 build 6 ), but every time I receive this message:
+===================================+
| Transport Disabled |
+===================================+
| Name: xxxxxxxxx
| Type: FTP
| Remote Host: xxxxxxxx
|
| Reason: Transport surpassed error threshhold with “21” errors
+===================================+
I can verify and enable the destination from WHM »Backup »Backup Configuration and I can reach my nas from shell without problems.

I've increased the value of error threshold in /var/cpanel/backups/config from 3 to 20 but with no luck, and i have increased backup timeout value in seconds up to 50000, but I still can't use my nas as additional destination.

Have you any suggestion?

Thanks
Alessio
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Hello :)

Do you notice any specific errors in /usr/local/cpanel/logs/cpbackup_transporter.log or in the appropriate log file in /usr/local/cpanel/logs/cpbackup related to the additional local destination?

Thank you.
 

Skin

Well-Known Member
Feb 3, 2006
93
4
158
Italy
Hello, thanks for your reply.
In /usr/local/cpanel/logs/cpbackup I can see this message, but everything else look ok:
[backup] System backups will not be uploaded to any remote destinations
And in /usr/local/cpanel/logs/cpbackup_transporter.log there are a lot of errors like this :
Code:
[2013-07-04 17:34:20 +0200] warn [cpbackup_transporter] Upload attempt failed: Could not create file.
 at /usr/local/cpanel/Cpanel/LoggerAdapter.pm line 26
	Cpanel::LoggerAdapter::warn(Cpanel::LoggerAdapter=HASH(0x243bc40), 'Upload attempt failed: Could not create file.\x0A') called at /usr/local/cpanel/Cpanel/Backup/Queue.pm line 219
	Cpanel::Backup::Queue::transport_backup::attempt_to_upload_file(Cpanel::Backup::Queue::transport_backup=HASH(0x240ede8), Cpanel::Transport::Files::FTP=HASH(0x2c613c0), '/backup/2013-07-04/accounts/pointnet.tar.gz', '/sdb1/cpanelbackup/2013-07-04/pointnet.tar.gz', Cpanel::LoggerAdapter=HASH(0x243bc40)) called at /usr/local/cpanel/Cpanel/Backup/Queue.pm line 135
	Cpanel::Backup::Queue::transport_backup::process_task(Cpanel::Backup::Queue::transport_backup=HASH(0x240ede8), cPanel::TaskQueue::Task=HASH(0x2c554e0), Cpanel::LoggerAdapter=HASH(0x243bc40)) called at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/cPanel/TaskQueue.pm line 571
	eval {...} called at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/cPanel/TaskQueue.pm line 574
	cPanel::TaskQueue::__ANON__() called at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/cPanel/StateFile.pm line 246
	eval {...} called at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/cPanel/StateFile.pm line 246
	cPanel::StateFile::Guard::call_unlocked(cPanel::StateFile::Guard=HASH(0x2ce7848), CODE(0x2d01b28)) called at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/cPanel/TaskQueue.pm line 579
	cPanel::TaskQueue::process_next_task(cPanel::TaskQueue=HASH(0x24232e8)) called at /usr/local/cpanel/bin/cpbackup_transporter line 89
	eval {...} called at /usr/local/cpanel/bin/cpbackup_transporter line 87
[2013-07-04 17:34:20 +0200] info [cpbackup_transporter] cPanel Backup Transporter Queue Daemon is being stopped.

[2013-07-04 17:35:01 +0200] info [cpbackup_transporter] cPanel Backup Transporter Queue Daemon started.

[2013-07-04 17:35:01 +0200] info [cpbackup_transporter] cPanel Backup Transporter Queue Daemon is being stopped.

[2013-07-04 17:35:11 +0200] info [cpbackup_transporter] cPanel Backup Transporter Queue Daemon started.
Alessio
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Could you open a support ticket so we can take a closer look? You can open a ticket via:

Submit A Ticket

Please post the ticket number here so we can update this thread with the outcome.

Thank you.
 

Skin

Well-Known Member
Feb 3, 2006
93
4
158
Italy
Hello,
I've just submitted a ticket, request id is: 4286213.

Thanks
Alessio
 

Skin

Well-Known Member
Feb 3, 2006
93
4
158
Italy
Hello, probably the problem is solved, first of all I should thank CPanel staff, cPanelMichael who started to help and Phil Stark.

The problem was related to my NAS which is associated to a dynamic dns service and the firewall ( in this case CSF ) which was blocking my ip adress for port scanning.

The solution is to edit csf.conf and enable the section dedicated to dynamic DNS:
# If you wish to allow access from dynamic DNS records (for example if your IP
# address changes whenever you connect to the internet but you have a dedicated
# dynamic DNS record from the likes of dyndns.org) then you can list the FQDN
# records in csf.dyndns and then set the following to the number of seconds to
# poll for a change in the IP address. If the IP address has changed iptables
# will be updated.
#
# A setting of 600 would check for IP updates every 10 minutes. Set the value
# to 0 to disable the feature
DYNDNS = 600
after enabling and setting DYNDNS csf.conf, you should edit csf.dyndns and add your hostname :
###############################################################################
# Copyright 2006-2013, Way to the Web Limited
# URL: ConfigServer Services
# Email: - removed -
###############################################################################
# The following FQDN's will be allowed through the firewall. This is controlled
# by lfd which checks the DNS resolution of the FQDN and adds the ip address
# into the ALLOWDYNIN and ALLOWDYNOUT iptables chains. lfd will check for IP
# updates every DYNDNS seconds if set
#
# Only list fully qualified domain names (FQDN's) in this file, either on their
# own to allow full access, or using Advanced Allow/Deny Filters (see
# readme.txt)
#

hostname.dyndnsservice.com
restart csf and lfd and everithing should work.

Alessio
 
Last edited:

Skin

Well-Known Member
Feb 3, 2006
93
4
158
Italy
The problem is not solved, backup worked once, but now every time I make a backup I receive this message again:
+===================================+
| Transport Disabled |
+===================================+
| Name: xxxxxxxxx
| Type: FTP
| Remote Host: xxxxxxxx
|
| Reason: Transport surpassed error threshhold with “21” errors
+===================================+
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
The problem is not solved, backup worked once, but now every time I make a backup I receive this message again:
Could you reply to the ticket with this information so we can continue to troubleshoot the issue?

Thank you.
 

Skin

Well-Known Member
Feb 3, 2006
93
4
158
Italy
Could you reply to the ticket with this information so we can continue to troubleshoot the issue?

Thank you.
Just done, thanks

- - - Updated - - -

It is a strange problem, because from shell I can connect to my nas, I can create, modify and delete files and directories.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
To update, it looks like the issue has no longer occurred after using a different hostname for the remote destination.

Thank you.
 

Skin

Well-Known Member
Feb 3, 2006
93
4
158
Italy
Hello, I still can't use my local NAS, I think that the problem is my local ftp server.
I've installed a custom firmware and I'm using VSFTPD as ftp server, now I'm tryng to configure my local ftp server, here is my vsftpd.conf, but I have the same identical problem:
:
# Standalone mode
listen=YES
max_clients=0
max_per_ip=0
# Access rights
anonymous_enable=NO
local_enable=YES
write_enable=YES
nopriv_user=root
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
# Security
anon_world_readable_only=YES
connect_from_port_20=YES
hide_ids=YES
pasv_min_port=50000
pasv_max_port=60000
# Features
xferlog_enable=NO
syslog_enable=NO
ls_recurse_enable=NO
ascii_download_enable=NO
async_abor_enable=YES
# Performance
one_process_model=NO
idle_session_timeout=120
data_connection_timeout=300
accept_timeout=60
connect_timeout=60
anon_max_rate=50000
# rt-ac
chroot_local_user=YES
local_umask=000
dirmessage_enable=YES
use_sendfile=NO
pasv_enable=YES
ssl_enable=NO
tcp_wrappers=NO
ftp_username=anonymous
ftpd_banner=Welcome to the jungle.
may be I'm doing something wrong?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Hello, I still can't use my local NAS, I think that the problem is my local ftp server.
I've installed a custom firmware and I'm using VSFTPD as ftp server, now I'm tryng to configure my local ftp server, here is my vsftpd.conf, but I have the same identical problem. may be I'm doing something wrong?
You can re-open the ticket if the issue continues so we can continue to investigate and attempt to reproduce the issue if necessary.

Thank you.