New backup system, not making new backups or deleting old

xunderworldx

Registered
Oct 30, 2013
3
0
1
cPanel Access Level
Website Owner
I left legacy to use the new backup system.. However it seems to be bugged, I made it to retain 2 daily & 1 monthly. However it keeps creating a folder everyday and it seems to have retained 3.

Problem is it wont delete old, keeps making a new folder everyday but does not place the new backup in it!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Hello :)

Please review the backup logs within the following directory:

Code:
/usr/local/cpanel/logs/cpbackup/
Do you notice any particular error messages?

Thank you.
 

xunderworldx

Registered
Oct 30, 2013
3
0
1
cPanel Access Level
Website Owner
I get the logs by email every time they occur.. I don't see anything to indicated that there is problems.. Today for example it finally worked but didn't do the monthly one. The monthly backup folder it made was completely empty.

The log that I got though didn't have anything about monthly in it.

The legacy backup used to include ftp connection log to it, these logs don't show anything about the ftp backup. So I'm not sure at all why it isn't doing them properly. May have to switch to legacy at this point as this isn't reliable.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
The remote FTP backup activity is logged to:

/usr/local/cpanel/logs/cpbackup_transporter.log

Feel free to open a support ticket if you want us to take a closer look:

Submit A Ticket

You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

xunderworldx

Registered
Oct 30, 2013
3
0
1
cPanel Access Level
Website Owner
My server admin said that there was backup process that were hung/not completing that were effecting new ones. He cleared them up & things seem to be alright. I will let you know if the problem comes back.
 

florenceit

Member
Jan 11, 2010
16
0
51
My server admin said that there was backup process that were hung/not completing that were effecting new ones. He cleared them up & things seem to be alright. I will let you know if the problem comes back.
Ive been having the same issue where backups fail randomly on 3 separate vps's ever since the new cpanel backup came out.

my last backup was two days ago, i see nothing abnormal in the last successful backup log, they just stop working.


my server company also gave me the same answer about a hung backup process. where can i find this and clear it myself?

thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
You can use a command such as "ps auxf" to see the existing processes on your system.

Thank you.