The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

new buildapache.sea issues!! Zend compatability?

Discussion in 'EasyApache' started by btrieve, Jan 31, 2003.

  1. btrieve

    btrieve Well-Known Member
    PartnerNOC

    Joined:
    Mar 20, 2002
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Here's the error:

    Zend Optimizer requires Zend Engine API version 20020429.
    The Zend Engine API version 20021010 which is installed, is newer. Contact
    Zend Technologies at http://www.zend.com/ for a later version of Zend
    Optimizer.


    This is after a buildapache.sea run. I don't see Zend support in any of the /script/Zend* files -- 4.2.3 and below -- the latest zend release at zend.com has 4.3 support -- is this a known issue here?
     
  2. btrieve

    btrieve Well-Known Member
    PartnerNOC

    Joined:
    Mar 20, 2002
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    also wanted to mention this is noted from execution of the php binary via cron or cli.

    The apache module appears to be running fine.
     
  3. btrieve

    btrieve Well-Known Member
    PartnerNOC

    Joined:
    Mar 20, 2002
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    pulling the library otu of the latest zend release at zend.com and manually overwriting the latest zend library cpanel has available resolved the problem.

    I would recommend resolving this at the cpanel level because I would expect others to have similar issues.
     
  4. gemby

    gemby Well-Known Member
    PartnerNOC

    Joined:
    Feb 16, 2002
    Messages:
    182
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Pula, Croatia
    cPanel Access Level:
    DataCenter Provider
    Upgrade went fine, but i still have php 4.2.3

    On the end of build, script says:

    Installing PHP SAPI module
    cp: cannot stat `sapi/cgi/php': No such file or directory
    make: *** [install-sapi] Error 1
    13044

    Restart went fine, apache is stable, but cpanel and phpinfo() says that i still have php 4.2.3 :-(
    I used custom instalation, and pick gd, freetype, curl, curlSSL, mcrypt, flash, ming, imap, everything work as should, but still no php 4.3.0, what's wrong?
     
  5. hostultra

    hostultra Well-Known Member

    Joined:
    Aug 21, 2002
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Can someone please tell me how to get an older version of buildapache.sea

    ALL my CGI scripts stopped working after installing this
    Nothing works that i have tried, to fix it!!
    I tried reinstalling cpanel aswell, as well as upgrading, downgrading...
    Its just screwed

    Not even cpanels own cgi scripts will work
    nothing .cgi works!

    In the error log it just says premature end of script headers

    I think its to do with suExec but i dont know how to fix it or uninstall suExec??
     
  6. elenlace

    elenlace Well-Known Member

    Joined:
    Sep 10, 2002
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    Hi,

    I have rebuilt Apache using the easyapache script as of yesterday with no major issues or errors. However, I do get the PHP 4.2.3 version when using phpinfo(), but when I look at WHM -& Server Status -& Apache Status I get version 4.3.0.

    Pretty strange... How do I know which version I'm running and if I need 4.3.0, how can I replace 4.2.3 with it?

    Many thanks in advance.

    elenlace.com - Mexico
     
  7. DuncanMcLord

    DuncanMcLord Active Member

    Joined:
    Dec 12, 2001
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    [quote:77394d23d4][i:77394d23d4]Originally posted by gemby[/i:77394d23d4]

    On the end of build, script says:

    Installing PHP SAPI module
    cp: cannot stat `sapi/cgi/php': No such file or directory
    make: *** [install-sapi] Error 1
    13044

    Restart went fine, apache is stable, but cpanel and phpinfo() says that i still have php 4.2.3 :-(
    I used custom instalation, and pick gd, freetype, curl, curlSSL, mcrypt, flash, ming, imap, everything work as should, but still no php 4.3.0, what's wrong?[/quote:77394d23d4]

    i am experiencing the exact same problem.
    latest buildapache refuses to install 4.3.0.
    ...any info on that error?
     
  8. DuncanMcLord

    DuncanMcLord Active Member

    Joined:
    Dec 12, 2001
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    ok,
    so you mean to run ./buildapache/buildapache, then install the Zend 2.1.0 and afterwards run ./buildapache/buildscript ?

    Well,
    i installed it on several machines successfully as well recently and haven't had problems with it in months, but on this machine it seems to be totally messed up, because it refuses to compile with any but a few exceptions in the php module section (php 4.2.3.) and won't compile at all with php 4.3.0.
     
  9. norm

    norm Well-Known Member

    Joined:
    Apr 23, 2002
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Maybe you could give us some example error messages?

    [quote:3d34056074][i:3d34056074]Originally posted by DuncanMcLord[/i:3d34056074]

    ok,
    so you mean to run ./buildapache/buildapache, then install the Zend 2.1.0 and afterwards run ./buildapache/buildscript ?

    Well,
    i installed it on several machines successfully as well recently and haven't had problems with it in months, but on this machine it seems to be totally messed up, because it refuses to compile with any but a few exceptions in the php module section (php 4.2.3.) and won't compile at all with php 4.3.0.
    [/quote:3d34056074]
     
  10. DuncanMcLord

    DuncanMcLord Active Member

    Joined:
    Dec 12, 2001
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    sure:

    this comes up with php 4.3.0. (no matter which config settings):

    Installing PHP SAPI module
    cp: cannot stat `sapi/cgi/php': No such file or directory
    make: *** [install-sapi] Error 1
    13044

    php 4.2.3. only works without GD & imap, once you try either of them it results in a file not found error in the modules dirs. (i don't have the exact messages, though)
     
  11. hostcp3

    hostcp3 Well-Known Member

    Joined:
    Jun 18, 2002
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16
    Guys on this subject what causes this

    Warning: setlocale() [function.setlocale]: Passing locale category name as string is deprecated. Use the LC_* -constants instead.

    I ran the php update and managed to get version 4.3 with this configuration:

    './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-swf=/usr/local/flash' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--with-mcrypt' '--with-ming=../ming-0.2a' '--enable-magic-quotes' '--with-mysql' '--with-pear' '--enable-sockets' '--enable-track-vars' '--enable-versioning' '--with-zlib'


    thankyou for any assistance.
     
  12. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    For your setlocale error, remove the double quotes from around the different instances of "LC_TIME" on the lines/files mentioned. That's a nuke problem we saw when we moved to 4.3.0. Getting Zend optimizer 2.1.0 working with php 4.3.0 hasn't been anything remotely approaching a success for us - we had to drop back to 2.0.3.
     
  13. hostcp3

    hostcp3 Well-Known Member

    Joined:
    Jun 18, 2002
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16
    Annette

    there you go, put my post in with guys and thought at the time how lazy I was not addressing the forum as people or guys/girls

    sorry. :(

    thanks for the info, yes indeed its an error on a phpnuke site we run.

    ok, so clients need to edit their code or we revert back to version 2.0.3

    thankyou.
     
  14. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    Don't worry about it. I address everyone as "guys", too. :)
     

Share This Page