SOLVED New Database not showing in phpMyAdmin

sparek-3

Well-Known Member
Aug 10, 2002
1,985
218
343
cPanel Access Level
Root Administrator
Not sure how long this has been going on or maybe I have an option configured wrong.

When you create a new database in a user's cPanel and then go to phpMyAdmin, the database is not listed. You have to log out of the cPanel and log back in and then it is showing in phpMyAdmin.

Is this functionality (or lack of) controlled by an option some where? Or is this something new? Is anybody else able to duplicate this?

I am seeing this behavior in cPanel 11.74.0.9 with MariaDB 10.1.36
 

linux4me2

Well-Known Member
Aug 21, 2015
259
78
78
USA
cPanel Access Level
Root Administrator
I'm using the same version of cPanel, but MariaDB v. 10.2, and I can't duplicate it. Databases newly created in cPanel show up immediately in phpMyAdmin without a reboot. On the Tweak Settings SQL tab, I have the defaults except for:
  • Allow cPanel & WHM to determine the best value for your MySQL open_files_limit configuration
  • Allow cPanel & WHM to determine the best value for your MySQL max_allowed_packet configuration
Neither of those settings seems like it would have anything to do with your issue. It almost sounds like you're looking at a cached version of phpMyAdmin, but I'm not sure how that would happen.
 

sparek-3

Well-Known Member
Aug 10, 2002
1,985
218
343
cPanel Access Level
Root Administrator
Thanks for checking.

I guess that rules out a cPanel issue. I thought it was pretty strange that nobody else had mentioned this issue.

It must be something specific that I have set up. I will look at it a bit more in-depth tomorrow.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello @sparek-3,

Can you verify if the "Enable phpMyAdmin information schema searches" option is disabled under the Software tab in WHM >> Tweak Settings? Per it's description:

If between 100 and 1,000 databases exist on your server, you can disable this option to attempt to increase performance. However, cPanel users must relog in to cPanel to allow phpMyAdmin to display newly-created databases.

Thank you.
 

zainhosting

Registered
Jun 14, 2019
4
0
1
Lahore
cPanel Access Level
Root Administrator
I think 'Enable phpMyAdmin information schema searches' option is disabled in your Cpanel, please check it here
Home -> Server Configuration -> Tweak Settings, click on the Software tab and disable phpMyAdmin information schema searches.