The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New DNS Cluster Servers Not Fully Syncing

Discussion in 'Bind / DNS / Nameserver Issues' started by gdgray, Oct 9, 2008.

  1. gdgray

    gdgray Member

    Joined:
    Nov 11, 2004
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    I'm transitioning between hosting companies and trying to add in the new DNS servers to the cluster to facilitate the transfer. My problem is that the the new DNS servers will not fully sync with the old ones. They only pick up about 20% of the domain names.

    I have the following setup:

    NS1 (DNS-Only) and NS2 (Full WHM a.k.a. HOST2) are the existing DNS servers.
    N1 (DNS-Only) and N2 (DNS-Only) are the new name servers.

    HOST2 (a.k.a. NS2) thru HOST6 are the existing hosting servers.
    H1 thru H5 are the new hosting servers.

    H1 thru H5 do not have any accounts yet.

    NS1: Synchronizing with NS2, N1, N2; Standalone with HOST3 - HOST6, and H1 - H5
    NS2: Synchronizing with NS1
    N1: Synchronizing with NS1
    N2: Synchronizing with NS1

    HOST2: Synchronizing with NS1
    HOST3: Synchronizing with NS1
    HOST4: Synchronizing with NS1
    HOST5: Synchronizing with NS1
    HOST6: Synchronizing with NS1

    H1: Synchronizing with NS1
    H2: Synchronizing with NS1
    H3: Synchronizing with NS1
    H4: Synchronizing with NS1
    H5: Synchronizing with NS1

    Anyone have any ideas why N1 and N2 will not completely sync with NS1?

    (BTW, the documentation is really weak on explaining the details of clustering - the only good info comes from this forum. Open Source projects usually have better documentation than this Commercial product. I guess I just expect more when I'm paying for it).
     
  2. gdgray

    gdgray Member

    Joined:
    Nov 11, 2004
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    I just looked in /var/named and I can see all the domain zone files have synced. However, when I restart bind on that server, only about 20% of the domains are displaying in the output.
     
Loading...

Share This Page