The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New DNS Only - synchronize doesn't add domains to named.conf

Discussion in 'Bind / DNS / Nameserver Issues' started by sneader, Dec 31, 2007.

  1. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I have 3 cPanel servers and one DNS only server. All 3 cPanel servers are "clustered" to the DNS-only server, and that is working very well.

    I am now trying to add a second DNS only server. I have them all properly clustered (easy). When I use the "synchronize" feature on each cPanel server, the zone files all transferred over (also easy).

    PROBLEM: The new DNS-only server does not respond authoritatively for any of the domains in question. Even though the zone files transferred over, those domains are not showing up in the named.conf file.

    Short of copying my other DNS-only named.conf file over, how can I properly get named.conf to add all my zone files to itself?

    EDIT: As long as I'm asking for help with this new DNS-only server, maybe you can help with this question as well.... The log e-mails that the server generates are going to the file /var/spool/mail/root. How can I get this mail to be forwarded to an external address?

    - Scott
     
    #1 sneader, Dec 31, 2007
    Last edited: Dec 31, 2007
  2. opt2bout

    opt2bout Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    After a manual edit/fix, it will work

    I had the same exact problem. One cpanel and one dns-only server. The named.conf did not propagate but the zone files did.

    For me, I had to manually edit the named.conf and the named.conf,v files on the DNS-ONLY server to include the zone statemetns (I just cut & pasted the entries for the includes on my primary cPanel server).

    NOTE: My primary cPanel is running on RHEL 4.0 and my DNS ONLY is running on CentOS 5.0. They are running different named versions. My CentOS server's named.conf uses VIEWS, and my cpanel server isn't. When I edited the DNS ONLY server's config files, I had to be sure to include the zone statements in both the INTERNAL and EXTERNAL views.

    Now, once I copied all of the zones over and restarted the named service, everything was fine. I tested cpanel account creation, termination, and manual zone changes to the DNS on the primary server and the zone statements in the named.conf and named.conf,v files updated perfectly.

    There is another thread where I posted the same question, only there was no response.

    Regarding your Email...you can create a file named ".forward" in the root account's home directory with your external Email address.
     
  3. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Thanks for both pointers.

    For now, I copied the named.conf from the working DNS-only server to the new DNS-only server, and everything is working great!! (well, it was a direct copy EXCEPT for the RNDC Key stuff, which I left intact)

    The .forward also worked. I had actually done that before posting, but I didn't think it was working... but last night's upcp generated an e-mail and it did get forwarded.

    Happy New Year!!

    - Scott
     
  4. h4f

    h4f Well-Known Member

    Joined:
    Jun 5, 2007
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6

    besides .forwad you can add in mail aliases the second adress you want the mail to go to.

    Could you please do grep recent_domain /etc/named.conf on several servers you will see that they are double in them. (see another posting)
     
  5. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    You lost me regarding the mail alias, but the .forward is working, so guess it doesn't matter.

    No double entries in my /etc/named.conf

    - Scott
     
  6. h4f

    h4f Well-Known Member

    Joined:
    Jun 5, 2007
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    .forward is slower and can only used if the user is made.

    cat /etc/aliases
    and
    cat /etc/valiases/thedomainyouneed.foo
     
  7. johnmigen

    johnmigen Active Member

    Joined:
    Jan 19, 2008
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Hi all,

    This might come to late, but after the synchronization, the named.conf will not be automatically updated, you can simply use /scripts/rebuildnamedconf

    This command will automatically add all the entries and without fear of double entries
     
  8. jwave

    jwave Registered

    Joined:
    Nov 24, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi John,

    I am having the same problem and want to try your solution. What syntax do I use to run /scripts/rebuildnamedconf and also, is this something that I need to do on the host server that has the full DNS entries or on the second nameserver that is missing the entries?

    :confused:
     
  9. johnmigen

    johnmigen Active Member

    Joined:
    Jan 19, 2008
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    You just need to run via ssh in your second name server.
    /scripts/rebuildnamedconf

    I believed your host server has set the setting in Configure Cluster to Synchronise Changes.
     
  10. jwave

    jwave Registered

    Joined:
    Nov 24, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Perfect and thank you. Your help was most appreciated.

    Perfect and thank you. Your help was most appreciated.
     
Loading...

Share This Page