The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New domain Email login Failure

Discussion in 'E-mail Discussions' started by jrozycki, Aug 7, 2007.

  1. jrozycki

    jrozycki Member

    Joined:
    Aug 31, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    New domain entered in WHM, setup an email account, but can not login to the email part. Pretty sure password and user name is correct.

    Created a test email account on an existing domain in my WHM, and can login to webmail.

    Checked the log files but can't get any leads. I recall the same thing happening 6 months ago when I tweaked some security settings. But I fixed it back then. Can't remeber the exact fix.

    Seems that the email login failure happens only on this new domain. Are there setting specific for each domain somewhere in WHM?
     
  2. pr0gr4mm3r

    pr0gr4mm3r Member

    Joined:
    Aug 25, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I am having the same problem. Webmail does not work on newly created accounts. Have you found a solution, jrozycki?
     
  3. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    For shitsngrins restart Courier - /scripts/restartsrv_courier

    Then make sure you're logging in with the full email address and not just the username

    Check /var/log/maillog for login failures.

    Mike
     
  4. pr0gr4mm3r

    pr0gr4mm3r Member

    Joined:
    Aug 25, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Restart Courier didn't help. I am logging in with the full email address. I get to cPanel's mail management page, but it doesn't let me use any of the webmail programs. Also, I can't use an IMAP session with a mail client. POP3 works, however. This is only with new cPanel accounts. Existing mail accounts still work fine, and I can add email accounts on existing cPanel accounts with no problem.

    The last entry in the log file:

    Code:
    Sep 25 22:36:02 home imapd[8758]: Command stream end of file, while reading line user=x@x.com host=localhost [127.0.0.1]
    Thanks for any assistance.
     
  5. pr0gr4mm3r

    pr0gr4mm3r Member

    Joined:
    Aug 25, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Turns out that running the mail2dir conversion solved the problem.
     
Loading...

Share This Page