The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

new email account - chowned to wrong group

Discussion in 'E-mail Discussions' started by Blue Steel, Oct 7, 2005.

  1. Blue Steel

    Blue Steel Active Member

    Joined:
    Mar 4, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    i tell cpanel to create a new email account...

    it used to work fine and create the subsir under mail dir using account:mail now its assigning the owner:group to account:account not account:mail ..

    this seems to be causing mailbox almost full emails being sent while the emailboses are actually almost empty..

    please how do i find out whats doing this...

    at the moment i'm having to go in manially and chown to account:mail from account:account


    this is rather urgent... any help would be appreciated
    thanks in advance

    Cameron
     
  2. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    try the script

    /scripts/mailperm
     
  3. Blue Steel

    Blue Steel Active Member

    Joined:
    Mar 4, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I ran it and yes i fixes existing account ;) thanks...

    but new accounts are still being made using the wrong group :(
     
  4. Blue Steel

    Blue Steel Active Member

    Joined:
    Mar 4, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Someone else must have had this happen to them....

    its when its creating the new email account that things are going wrong...

    what gets me is that nothing changed on the system (as far as i know) it was working fine... then it just changed the group it was assigning the chown to whwn creating the new email accounts.. i don't know when it started as its only now that i've found the problem

    the script stated above fixes the dir's etc once they are created but thats not good enough.. i need to get it fixed to make it right in the first place

    someone must know whats happened... is there a setting i may inadvertantly changed...

    Note: even updating everything.. cpanel,system,server,addon scripts,apache, backend scripts ... hasn't repaired it... i'm now running cpanel 10.8

    please help
     
  5. Blue Steel

    Blue Steel Active Member

    Joined:
    Mar 4, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Someone out there must know whats happening on my system... I can't believe that this is only happened to me...

    BTW even after changed the froup manually to accountname:mail the users are still getting msgs that their mail is almost full.. when they arn't :(

    so i'm back to square one
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Since no-one else has posted, you should log a ticket through your cPanel license provider to have cPanel investigate for you.
     
  7. Secret Agent

    Secret Agent Guest

    I can duplicate this problem. I tried upgrading to CURRENT and ran these scripts

    /scripts/fixquotas
    /scripts/fixmailman
    /scripts/eximup --force
    /scripts/mailperm
     
  8. Blue Steel

    Blue Steel Active Member

    Joined:
    Mar 4, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Did running those scripts fix it...

    or did it replicate the error...

    ie: is it a fix or how to replicate it

    sorry ..
     
  9. Bravo

    Bravo Well-Known Member

    Joined:
    Oct 30, 2001
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Ownership for new email accts is account:account instead of account:mail on my server too.
    No box full messages though, I have not enabled this option in the server settings.
    However, I have a customer who is getting errors while trying to connect to those accounts via Outlook. His other accts work fine.
    Tried /scripts/mailperm but it did not change folder ownership.
     
  10. Secret Agent

    Secret Agent Guest

    Any fix for this yet?
     
  11. Blue Steel

    Blue Steel Active Member

    Joined:
    Mar 4, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    nope not as yet :(

    our hosting provider told me that they have put in a support ticket with cpanel.. (that was 6 days ago) and i'm still waiting to hear back
     
  12. Secret Agent

    Secret Agent Guest

    Can someone else duplicate this? Any cpanel tech to help out at least?
     
  13. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    As you well know, you need to log a ticket through your license provider if you want support from cPanel. Please stop bumping threads.
     
  14. Secret Agent

    Secret Agent Guest

    Thats why I do not submit tickets. I wait here instead.

    Still have no fix on my end. Anyone else figure it out?
     
Loading...

Share This Page