New Install Security Questions Issue

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
Hi, i just set up some of the cPanel WHM install and needed to take a break.

When i went back to log into root, it takes me to a page that says i have not yet set up security questions and tells me that i can choose existing questions or input my own.

First there is no dropdown at all when i press the down arrow, so there are no existing questions. I tried both on FF and on Chrome. Then even if i enter my own question and answers and click continue, it logs me off and when i go to log in again im right back at the same questions screen..

Whats going on ? Did i miss something ?

Thanks

UPDATE: I guess i could just disable them via ssh here
Configure Security Policies - Version 68 Documentation - cPanel Documentation
 
Last edited:

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
well that didnt work... now when i log in i get the menu with no styling theme at all (see pic) and whenever i click on anything at all it logs me off.

notheme.jpg
 

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
well thats not it yet, seems it works http but not https, so maybe when i get the site moved over officially it will be https then... but im thinking it should already be https even with just the hostname and whm pointed to the server from cloudflare.

so whm access via ip works http but not https

and whm access via hostname works https but whm bombs with no template and then craps out after login...

maybe the ip is not resolving to the hostname


Your connection to this site is not secure

but then im back to it failing with no template as in the image.

OK i think this is the fix... we will see

nope still the same hostname shows hostname and

Can't Access My Hostname

nope still the same

hostname shows the hostname
dig shows my ip address

so what i did was since i use cloudflare for my dns i disabled dns on the server.

so now what ill try is changing the pointer in cloudflare for my root domain xxxxx.com to point to the shared ip on the server and see if thats the problem is that i have hostname and whm pointing to the server ip but not the base domain.

same freaken problem... GRRRRRRRRRRRR

so everything is pointing now to the server and still same problem...

and so i logged into cpanel to check it and same thing it loads, no template, then crashes when you select something.


cpanelnotheme.jpg


Why dont you all have some kind of help message, error, on the screen if it cant load the freaken template.

At least give us stupid people a clue as to what it might be, error or something!! geeeesssss

so now im lost i dont know what to do next ! and here i sit with my head in my lap..

ok lets try this
My cPanel won't load or keeps logging me out after enabling Cloudflare

from this article i love this line :)

Note: Starting with version 64 of WHM this is no longer an issue. Although it is possible that under some conditions this will still be noted. If this is the case please apply the solution above.
LMAO its like saying go ahead cross the river i promise the bridge is fixed, but just in case it breaks while your on it, here is a rope LMAO
 
Last edited:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
Hi @durangod

from this article i love this line :)

LMAO its like saying go ahead cross the river i promise the bridge is fixed, but just in case it breaks while your on it, here is a rope LMAO
I've always thought that was pretty funny too, it is still definitely an issue when CloudFlare is enabled. Are you still experiencing an issue or did this article resolve it for you?

Thanks!
 

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
Hi, good morning.... :) yes i am still having the issue. I have discovered that my main domain is still pointing at the server rather than at cloudflare. It was pointing at cloudflare early yesterday so not sure what happened.

Anyway so that domain is on a dedicated ip, i cant change the ip of the domain in whm because it wont let me modify the site ip to the cloudflare ip.

Can i use the add ip in whm to add a cloudflare ip so i can assign it to the site? Its not going to mess with CF is it, i mean adding their ip to my server just so i can have it on the list?

I tried to add an A record via cpanel but it told me that the feature needed to be added and i dont know where that is in WHM.

I keep thinking that if i am going to use cloudflare then i dont need DNS on the server and i can disable it, is that correct?
 
Last edited:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
Hi @durangod


While you could potentially add the CloudFlare IP to the server there really isn't a point in doing this. I'm not sure I understand where you're encountering the issue - if you're pointing your nameservers to Cloudflare then in CloudFlare it's showing your DNS zones properly you should technically have configured CloudFlare properly.

Once CloudFlare is set up you're technically not even hosting DNS on the server (but keep in mind it pulls your records from the server initially) so you could disable the nameserver if you wish.
If you're experiencing an issue with the format of the cPanel/WHM like the UI is not completely loading still you will need to access using a method that is not proxied through CloudFlare such as the IP address. The only other option would be to stop proxying the hostname, meaning ensure that the hostname of the server has a grey cloud rather than an orange one. That way you could access cPanel/WHM through the hostname of the server.

Thanks!
 

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
hi issue is not resolve but i did get ssl up and running for everything else and my free cert from cloudflare installed on both whm and cpanel. However ssl still does not work for cpanel and whm but works great for the websites. I understand they are different monsters. It does show the right cert from CF in both places.

So i went to the redirection tab in tweek settings to redirect to ssl and its all greyed out, i cant change it. Oh and i tried to run autossl and it just ran forever and did nothing so i just killed the job.

I guess i missed doing something somewhere huh :)
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
Hi @durangod

To clarify
hi issue is not resolve but i did get ssl up and running for everything else and my free cert from cloudflare installed on both whm and cpanel.
Are you using the certificate provided by CloudFlare? Are you aware if it covers whm. or cpanel. subdomains as part of the SAN's?

That's the only reason I can think that redirect to SSL would be greyed out unless you have the setting as follows enabled:

Choose the closest matched domain for which that the system has a valid certificate when redirecting from non-SSL to SSL URLs. Formerly known as “Always redirect to SSL/TLS”


Thanks!
 

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
certcloud.jpg redirect.jpg hi, yes it covers *.site.com and site.com see images
 
Last edited:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
Hi @durangod

If the CloudFlare certificate isn't covering the sites you need to address that with them. The certificate isn't actually installed on the server in the case of this - it's installed through their cached copy.

For the image of tweak settings - as I mentioned before the only reason those options would be greyed out is if you had "Choose the closest matched domain for which that the system has a valid certificate when redirecting from non-SSL to SSL URLs. Formerly known as “Always redirect to SSL/TLS” " enabled which you do according to the screenshot
 

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
oh so just turn it off and the other ones light up... lol ok

here is what it said when i saved it... i set it to hostname and then i tried doman and still the same invalid message.



Invalid value for “autodiscover_host”: “autodiscover_host” - autodiscover_host requires autodiscover_proxy_subdomains. This setting will not be updated.

Invalid value for “autodiscover_mail_service”: “autodiscover_mail_service” - autodiscover_mail_service requires autodiscover_proxy_subdomains. This setting will not be updated.

Your changes have been saved.

Restarting cPanel daemons...done.

Updating your system to reflect any changes...
Updating “Choose the closest matched domain for which that the system has a valid certificate when redirecting from non-SSL to SSL URLs. Formerly known as “Always redirect to SSL/TLS”” from “On” to “Off”.
“Choose the closest matched domain for which that the system has a valid certificate when redirecting from non-SSL to SSL URLs. Formerly known as “Always redirect to SSL/TLS”” was updated.
Updating “SSL redirect destination” from “SSL Certificate Name” to “Hostname”.
“SSL redirect destination” was updated.
 
Last edited:

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
I just wanted to update this to be more clear on the solution when this happens. It means you need to use
literally:

whm.example.com:port or cpanel.example.com:port

until everything propagates and you have all your certs in place and
hostname set up. Then in a day or so it will all mesh and work using your hostname.example.com:port

so if your template is not loading and as soon as you click on something it logs you off, then this is the solution. I just went through this again and im glad i found my old post here. :)
 
  • Like
Reactions: cPanelLauren