The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

new kernel kernel-2.4.21-37.EL

Discussion in 'General Discussion' started by sh4ka, Oct 7, 2005.

  1. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    Latest kernel installed, but don't booting ¿?

    is recommended to update the kernel version to this new one ? I run RH-AS 3.
     
    #1 sh4ka, Oct 7, 2005
    Last edited: Oct 7, 2005
  2. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    I always install the new kernel ASAP when released by RHN. I've been running 2.4.21-37.EL for 8 days (in 3 hours).
     
  3. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    As usual I used "up2date --configure" to remove kernel from the skip list, the run: "up2date -u" and kernel was installed with new version. But after the reboot it still booting with the old kernel, anyone knows how to fix it? First time I see this after updating the kernel..
     
  4. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    First off, you can leave it in the skip list and just do up2date -uf kernel (or kernel-smp, etc.). The -f option forces it.

    Secondly, check /boot/grub/grub.conf. Make sure the 2.4.21-37.EL kernel is the first one listed and that the default option at the top of the config (below the documentation) is set to 0.
     
  5. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    Latest kernel installed, but don't booting ¿?

    Why the kernel is not booting!!if it is located first at the grub.conf :S ?????????????? :confused:
    I always use this way to upgrade the kernel version.. Any ideas ?

    Code:
    title Red Hat Enterprise Linux ES (2.4.21-37.ELsmp)
            root (hd0,0)
            kernel /vmlinuz-2.4.21-37.ELsmp ro root=/dev/sda3
            initrd /initrd-2.4.21-37.ELsmp.img
    .......
    
     
    #5 sh4ka, Oct 7, 2005
    Last edited: Oct 7, 2005
  6. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    Sorry for my ignorance...
    Now i realize you mean this:
    default=2

    I will change it to 0 and try. Thank you.
     
  7. Silverado_HD350

    Silverado_HD350 Registered

    Joined:
    Jul 31, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    should there be a line break between the 2 different kernel versions?


    title Red Hat Enterprise Linux ES (2.4.21-37.ELsmp)
    root (hd0,0)
    kernel /vmlinuz-2.4.21-37.ELsmp ro root=LABEL=/
    initrd /initrd-2.4.21-37.ELsmp.img
    title Red Hat Enterprise Linux ES (2.4.21-37.EL)
    root (hd0,0)
    kernel /vmlinuz-2.4.21-37.EL ro root=LABEL=/
    initrd /initrd-2.4.21-37.EL.img
    title Red Hat Enterprise Linux ES (2.4.21-32.0.1.ELsmp)
    root (hd0,0)
    kernel /vmlinuz-2.4.21-32.0.1.ELsmp ro root=LABEL=/
    initrd /initrd-2.4.21-32.0.1.ELsmp.img
    title Red Hat Enterprise Linux ES (2.4.21-32.0.1.EL)
    root (hd0,0)
    kernel /vmlinuz-2.4.21-32.0.1.EL ro root=LABEL=/
    initrd /initrd-2.4.21-32.0.1.EL.img
     
  8. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    It doesn't really matter. By default, there's no line breakes, however you can manually enter line breaks in if you really want to.
     
  9. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    I spoke with my DataCenter about this and they told me:

    "Below are the contents of your /etc/lilo.conf file:
    Code:
    root@server [~]# cat /etc/lilo.conf
    prompt
    timeout=50
    default=linux
    boot=/dev/sda
    map=/boot/map
    install=/boot/boot.b
    message=/boot/message
    linear
    
    image=/boot/vmlinuz-2.4.21-37.ELsmp
    label=2.4.21-37.ELsmp
    initrd=/boot/initrd-2.4.21-37.ELsmp.img
    read-only
    append=" root=/dev/sda3" 
    
    image=/boot/vmlinuz-2.4.21-37.EL
    label=2.4.21-37.EL
    initrd=/boot/initrd-2.4.21-37.EL.img
    read-only
    append=" root=/dev/sda3" 
    
    image=/boot/vmlinuz-2.4.21-32.0.1..ELsmp
    label=linux
    initrd=/boot/initrd-2.4.21-32.0.1..ELsmp.img
    read-only
    append=" root=LABEL=/" 
    
    image=/boot/vmlinuz-2.4.21-32.0.1..EL
    label=linux-up
    initrd=/boot/initrd-2.4.21-32.0.1..EL.img
    read-only
    append=" root=LABEL=/" 
    
    You will need to edit /etc/lilo.conf to make the latest SMP kernel the default. This would be the kernel with the label 2.4.21-37.ELsmp. Simply edit the default= line. Save the changes, and run /sbin/lilo for the changes to be written to the boot record. Then reboot your server, and it will be running the new default kernel."

    Is he talking about this line

    root@server [~]# cat /etc/lilo.conf
    prompt
    timeout=50
    default=linux------------------------------------> THIS! ?? What exaclty should I put there?

    And another important question, how can I know if my server uses grub or lilo to load the kernel ? Cos the new kernel is configured at grub too.. soo. ??¿?¿?
     
  10. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    Oh, you're using LILO :(

    Change default=linux to default=2.4.21-37.ELsmp
     
  11. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You would also then need to run:

    lilo -v -v
     
  12. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    Thank you guys! I'll try that.
     
  13. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    Thanks again, I just added new kernel version to the "default=" line, then run /sbin/lilo and the system rebooted with the new kernel. Chirpy, for what is -v -v parameters ? I didn't use those and new kernel booted without problems... ¿?
     
  14. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    the lilo -v -v loads your LILO configuation into the actual bootloader on the MBR, so next time it boots, it uses that config, because the /etc directory won't be mounted at that point. If you can, I'd suggest you find out which bootloader is actually being used and remove the other one because having two bootloaders causes some confusion like that.
     
  15. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    As I told before, I use lilo, but after up2date completed kernel installation, new kernel was configurated at both config files (lilo and grub). runing /sbin/lilo does the same as -v -v options as far as I can see... ?¿
     
  16. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yes, it does the same, but -v -v gives you information about what it is doing (-v = verbose mode, two -v's means very verbose ;))
     
Loading...

Share This Page