The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

new server - ssi not being parsed - where to look?

Discussion in 'General Discussion' started by boatdesign, Feb 27, 2009.

  1. boatdesign

    boatdesign Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    16
    New server. Running apache 1.3.x. Transferred first accounts and see that my index.shtml file is not being parsed on the new server but is instead being spit out raw...
    loading in browser and viewing source on new server shows
    <!--#include virtual="/subdir/script.cgi?locale=us&Operation=ItemSearch&Keywords=deleted-for-forum-post" -->

    Any ideas on where to look first?

    Inputting http://domain.com/subdir/script.cgi?locale=us&Operation=ItemSearch&Keywords=deleted-for-forum-post works fine on the new server
     
  2. boatdesign

    boatdesign Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    16
    In WHM I have the following options checked under apache global options

    ExecCGI
    FollowSymLinks
    Includes
    Indexes
    SymLinksIfOwnerMatch

    However Includes are still not working
     
    #2 boatdesign, Feb 27, 2009
    Last edited: Feb 27, 2009
  3. boatdesign

    boatdesign Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    16
    Adding an .htaccess file with +Includes makes the .ssh be parsed - is there an easy option to allow .shtml ssi includes to be parsed that can be set from within whm, or do I need to manually edit the easy apache template? If so can anyone give me a quick tip on which template file I need to insert this option into?
     
Loading...

Share This Page