The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New server SSL not registering in WHM

Discussion in 'General Discussion' started by Boboss, Dec 7, 2007.

  1. Boboss

    Boboss Active Member

    Joined:
    May 26, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    151
    Strange thing happening to me.

    Last year, I installed a basic SSL certificate that I purchased from Geotrust to replace the default SSL that came with WHM. This worked perfectly and the certificate was validated and could be seen in the browser as perfectly valid.

    BUT, this year, I ordered a new SSL certificate from Geotrust again to replace the old one that was expiring. BUT, strangely, even though the new cert is being entered correctly in WHM, it does not seem to be updating properly in the browser. The browser is till showing me the old expired certificate, not the new one. As a result, Internet Explorer keeps complaining.

    How do I get this to work properly?

    Thanks.
     
  2. cpanelinfoseeker

    cpanelinfoseeker Well-Known Member

    Joined:
    Oct 25, 2002
    Messages:
    325
    Likes Received:
    3
    Trophy Points:
    168
    Location:
    NE Illinois
    cPanel Access Level:
    Root Administrator
    On my server I use:

    service cpanel restart

    through SSH to make the new certificate appear.
    Hope this helps,
    Ron
     
  3. Boboss

    Boboss Active Member

    Joined:
    May 26, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    151
    I tried it, but that does not work.

    Let me specify that this is related to the Server's main Certificate, the one needed by WHM to display in a secure environment. It looks as though the certificates I installed for reguslar site domain names are working fine. But the mai WHM certificate is the one not updating itself. And so, the server is stuck usin the expired Geotrust certificate.

    I am puzzled as to why the new certificate is not being read by the server. It comes up normally when I go the the Install Certificate window, which appears when I click on the "Install a SSL Certificate and Setup the Domain" link. When I click submit, it accepts the update without a problem, but when I go on to login, it still shows the exprired certificate, and of course, Internet Explorer 7 is complaining with a "Certificate error".:confused:
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,277
    Likes Received:
    8
    Trophy Points:
    313
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Have you attempted to install the certificate for cPanel/WHM/Webmail by going to WHM -> Service Configuration -> Manage Service SSL Certificates and installing a certificate for cPanel/WHM/Webmail Service? If not, give that a shot :).
     
  5. Boboss

    Boboss Active Member

    Joined:
    May 26, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    151
    It worked! Thanks.

    I had not realized there was a separate area for installing the cert for WHM.

    Thanks so much!
     
  6. Biotron2000

    Biotron2000 Active Member

    Joined:
    Jul 20, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    156
    Thanks, this fixed my expired SSL issue also.
     
Loading...

Share This Page