The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New SSL Cert expired / not recognized

Discussion in 'General Discussion' started by Edward123, May 1, 2005.

  1. Edward123

    Edward123 Member

    Joined:
    Jul 13, 2004
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    I've installed a new cert (128 bit, from Verisign). The installation went as planned, or so it appeared. If you go there in IE, you get the message that the cert has expired or is not yet valid, but if you click to view the cert you can see that the dates are correct. If you go there in Netscape you get the message that the issuer is not recognized.

    Have uninstalled/reinstalled the cert - same result.

    It is on its own IP, etc.

    Any ideas?

    Chek it out here - https://secure.thebabybookboutique.com
     
  2. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    Using IE6 the certificate appears to be fine. No errors on page load and cert info all appears to be fine
     
  3. Edward123

    Edward123 Member

    Joined:
    Jul 13, 2004
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for checking. I'm on IE6 as well.

    I've had several friends & associates go to the page. Most get the date error, some don't.

    Anybody else seeing this?
     
  4. Trigger

    Trigger Well-Known Member

    Joined:
    May 17, 2003
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brisbane
    Your certificate dates are correct but the intermediate certificate used by verisign expired 08/01/2004

    Did you install the correct CA bundle with the certificate?
     
  5. Edward123

    Edward123 Member

    Joined:
    Jul 13, 2004
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Thanks!

    You are correct - I forgot that for the Verisign 128 bit (Pro) certs you need to install what they call the "Intermadiate CA", which they don't send along w/ the cert, nor do they tell you that it's needed.

    I knew this in my past life, but so much time has passed since then....

    Thanks again to all who checked into this!
     
    #5 Edward123, May 1, 2005
    Last edited: May 1, 2005
Loading...

Share This Page