The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New SSL Cert not working on 2096, 2087 or 2083

Discussion in 'Security' started by lishevita, May 14, 2013.

  1. lishevita

    lishevita Registered

    Joined:
    May 14, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    We just purchased and installed a new Trustwave certificate. If I go to the domain at https://mydomain.com it works fine, and I can see that the new certificate works and everything is hunky-peachy. If I go to the ports for whm, webmail or cpanel, however, it just gives me the evil red screen of insecurity, and says that only have a self-signed certificate.

    One post said that you should make sure that you have /usr/local/cpanel/var/run/stunnel. We do. It's there.

    Another post said to check to restart cpanel. Did that. No joy. In fact, I rebooted the whole server. Still no joy.

    Trustwave said that I need to bind the certificate to the other ports but that I'd have to find out how from the cpanel documentation. I've read through the documentation and can't find any mention of binding the certificate to any other ports.
     
  2. lishevita

    lishevita Registered

    Joined:
    May 14, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Found it. Finally!!!!

    Once the cert is set up for the server in general, you have to go to Service Configuration (underneath resellers) and set the service SSL certificates.
     

    Attached Files:

    #2 lishevita, May 14, 2013
    Last edited: May 14, 2013
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Yes, that is correct. You have to install the certificate for the services via:

    "WHM Home >> Service Configuration >> Manage Service SSL Certificates"

    This is documented at:

    Manage Service SSL Certificates

    Thank you.
     
Loading...

Share This Page