martinkrol

Registered
Jan 18, 2012
3
0
51
cPanel Access Level
Root Administrator
Hey there.

To start off, I have issues with my current WHM/apache install.

Some background. I have been using bluehost for years now, and am familiar with cPanel, dns zones, Cnames, ftp, using CDN services, etc.. but just recently I decided that moving to a VPS would be a good idea so I subscribed to a VPS with 512 ram, CentOS x64.

So I got WHM installed and a cPanel account up and running with my selected options. My Domain is set up from bluehost name servers and all is working fine.

Installed Joomla, then Joomsocial and that's where I started to notice problems. Joomsocial needed me to increase the max php upload to 4mb, ( i increased it to 5 just in case ). It uploaded fine with this setting. Next I noticed that zend framework wouldnt install, so I installed it manually. that worked too. I tried Joomsocial again, but now at the end of the install it tells me that i cant allocate enough memory. ( It I still have 40% of my memory intact. )

So I go back to square one, and look at the requirements for my extensions. I got a list of requirements, and found that I need to use EasyApache update to recompile PHP. I tried that, and selected the appropriate extensions. However, every time it fails to complete.

I have a few other issues, such as EasyApache taking FOREVER to load up. i see the message "Making sure we have the latest files..." for approx 20 minutes at a time. It makes it hard to make any sort of updates or test things out with this slow response.

To make matters worse, after I had the memory issue with joomla, and the memory allocation issue, I can now no longer access my website, period. it says there is an internal server problem.

when I go to //www.cgmechanic.com I should be seeing the install for joomla.
//http://www.cgmechanic.com/images/Holliday.jpg works, so the domain resolves fine.

There is another issue where I try to use yumrepo command, it says that all mirror URLs are not using ftp. http, or file.


So, to make a long thing short, I don't know where to start. I just know things seem broken, and I dont know how to make it work. Any help would be appreciated.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
Please open up a ticket for these setup issues. There are too many issues that would take a long time to sort via the forums. You can use the link in my signature to submit a ticket.

For the site issue with the internal server error, it is likely the PHP handler that's the issue or file permissions / ownership on the files. It might otherwise be due to EasyApache failing. Since we don't have the failure message to see why it is failing for that recompile, we couldn't troubleshoot it here to provide suggestions unfortunately.

Of note, you might try tailing the Apache error logs to see if you can glean further information for why the site is failing:

Code:
tail -fn0 /usr/local/apache/logs/error_log
Also, we would need the actual error for the yumrepo command rather than a synopsis of that error.
 

martinkrol

Registered
Jan 18, 2012
3
0
51
cPanel Access Level
Root Administrator
Hey.

I tried the tail command and here is what I get.

[Thu Jan 19 16:23:13 2012] [error] [client 108.162.134.210] File does not exist: /home/tofconst/public_html/favicon.ic o
[Thu Jan 19 16:23:13 2012] [error] [client 108.162.134.210] File does not exist: /home/tofconst/public_html/404.shtml
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello :)

Try using the "tail" command that Tristan provided just before you browse to the website. Then, once you encounter the error message, look to see if it displays the "500" error with the full details.

Were you able to open a support ticket for this issue? If so, you can post the ticket number here so we can track the issue.

Thank you.
 

martinkrol

Registered
Jan 18, 2012
3
0
51
cPanel Access Level
Root Administrator
Yep. I got the problem solved.

Opened a ticket, and Chris solved it in about 10 minutes, and he documented everything. Very good service.

Turns out I had an issue with Perl from the Operating system that was conflicting with cPanel. Once that was fixed, and cpanel was cleaned, all problems went away. I could compile Apache, the website launched, etc.

The only issue I have now is a statement on the bottom of my site on chrome telling me that I cant allocate enough memory. I think the only way to solve this one is to bump up the ram on the VPS. I guess 512 ram isn't enough to run joomla, jomsocial, and kunena all together.

I will keep this thread updated for future reference.

Here is what Chris did to fix the Perl issue.

So far I've noticed that you had two versions of Perl installed. One that we attempted to installed, and one that was provided by the OS or installed prior. This was causing some major conflicts within cPanel as cPanel runs primarily off of Perl 5.8.8 and has rolled back certain binaries to work with our software. I noticed it breaking immediately when checking the perl version with `perl -v`. I then moved the Perl directories out of the way and symlinked them. From there I attempted to re-install our Perl modules, which failed because they could not resolve successfully to the CPAN servers to obtain them. That being said, I changed your /etc/resolv.conf file to use Google.com's PublicDNS resolvers. Below you will see my actions thus far:

60 perl -V
61 ls -lah /usr/bin/perl
62 ls -lah /usr/local/bin/perl
63 free -m
64 mv /usr/bin/perl /usr/bin/perl.bak
65 ln -fs /usr/local/bin/perl /usr/bin/perl
66 mv /usr/lib/perl5/ /usr/lib/perl5.bak
67 ln -s /usr/local/lib/perl5/ /usr/bin/perl5
68 /scripts//checkperlmodules --full --force
69 cat /etc/hosts
70 ifconfig|grep 199.30.48.217
71 cat /etc/resolv.conf
72 mv /etc/resolv.conf /etc/resolv.conf.bak
73 echo -e "8.8.8.8\n8.8.4.4" > /etc/resolv.conf
74 /scripts//checkperlmodules --full --force


As cPanel was unable to install the correct Perl modules I'm slightly apprehensive as to what was installed with the rest of cPanel. That being said, I'm running another cPanel script which is `/scripts/upcp.static --force`, which will update any missing or out of data files from cPanel mirrors to ensure the software is up to date.

This may take a while, so I've installed screen with `yum install -y screen` and am running this update in screen here:

[email protected] [~]# screen -ls
There is a screen on:
7113.pts-0.server (Detached)
1 Socket in /var/run/screen/S-root.