The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

newbie dns problem

Discussion in 'Bind / DNS / Nameserver Issues' started by banosr, Nov 11, 2009.

  1. banosr

    banosr Registered

    Joined:
    Nov 11, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I configured everything but everyday I get an email stating a dns problem that:

    The hostname xxxx.xxxx.xxxx resolves to (public ip address). it should resolve to (private ip address).

    I have the server behind a router that forwards the public ip to the private ip.


    I will appreciate any help you may give me
     
  2. thewebhostingdi

    thewebhostingdi Well-Known Member

    Joined:
    Jan 10, 2008
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Please make sure that the A record for your domain points to your server Ip address? You can check it from the DNS zone editor. If the Ip address is not server Ip address then you will need to set the server's IP address.
     
  3. banosr

    banosr Registered

    Joined:
    Nov 11, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    main IP was the problem

    In basic cPanel/WHM Setup I changed the main Ethernet device from eth0 to eth0:1 to let the main IP be the public IP address instead of the private IP address and then then set the A record to public IP and it is working great.

    I hope it helps someone else
     
Loading...

Share This Page