Newer releases of cPanel & WHM are not compatible with your operating system

Shilpa George

Member
Jun 5, 2019
8
0
1
Bangalore, India
cPanel Access Level
Reseller Owner
Hello , We have received a notification from WHM that our cPanel Updates are failed . I have checked the update logs (Please find below) , Any Advise?


/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:00:42 +0000] [/usr/local/cpanel/scripts/rpmup] checkyum version 22.3 (excludes: bind-chroot kernel ruby)
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:00:45 +0000] [/usr/local/cpanel/scripts/rpmup] cpanel-analytics-1.3.3-1.1.noarch has missing requires of cpanel-version >= ('0', '73.0.0', None)
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:00:45 +0000] [/usr/local/cpanel/scripts/rpmup] checkyum version 22.3 (excludes: bind-chroot ruby)
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:00:46 +0000] [/usr/local/cpanel/scripts/sysup] checkyum version 22.3 (excludes: bind-chroot kernel ruby)
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:00:47 +0000] Processing: Migrating feature lists to current version (if needed)
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:00:51 +0000] - Processing command /usr/local/cpanel/scripts/findphpversion
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:00:51 +0000] [/usr/local/cpanel/scripts/findphpversion] PHP version file is up to date
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:00:51 +0000] - Finished command /usr/local/cpanel/scripts/findphpversion in 0.089 seconds
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:00:57 +0000] MySQL or MariaDB version “5.6” is less thanthe recommended minimum version, “5.7”.
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:01:00 +0000] [/usr/local/cpanel/scripts/spamassassin_dbm_cleaner] /usr/local/cpanel/scripts/spamassassin_dbm_cleaner: version 1.0
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:01:04 +0000] Processing: Checking End Of Life for current version.
/var/cpanel/updatelogs/update.1577426429.log:[2019-12-27 06:01:06 +0000] W [FATAL] - Newer releases of cPanel & WHM are not compatible with your operating system. Upgrade your OS, or use the Update Preferences screen to select a Long-Term Support release for use with your OS. Starting with version 57, cPanel & WHM supports 64-bit versions of CentOS 6+, Red Hat Enterprise Linux 6+, CloudLinux® 6+, and Amazon Linux 2015+ only. Please see our OS End of Life policy for more information.
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,914
910
313
cPanel Access Level
Root Administrator
Hey there! It looks like you may be running an operating system that is too old to support updates or a 32 bit version of the operating system. Can you run the following two commands and send us the results?

uname -a
cat /etc/redhat-release
 

Shilpa George

Member
Jun 5, 2019
8
0
1
Bangalore, India
cPanel Access Level
Reseller Owner
Thank you so much for checking .

Sure , Please find the results below:

# uname -a
Linux server.example.com 4.9.20-11.31.amzn1.x86_64 #1 SMP Thu Apr 13 01:53:57 UTC 2017 x86_64 x86_64 x86_64GNU/Linux

[[email protected] /]# cat /etc/redhat-release
cat: /etc/redhat-release: No such file or directory
[[email protected] etc]# cat redhat-release
cat: redhat-release: No such file or directory
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,914
910
313
cPanel Access Level
Root Administrator