Operating System & Version
CentOS7.9
cPanel & WHM Version
106.0.8

matt1206

Well-Known Member
Dec 20, 2011
56
9
58
cPanel Access Level
Root Administrator
Code:
2022/09/30 00:40:18 [emerg] 20297#20297: unknown "cpanel_service_subdomain" variable
2022/09/30 00:40:19 [emerg] 20491#20491: unknown "cpanel_service_subdomain" variable
2022/09/30 00:40:38 [emerg] 21968#21968: unknown "cpanel_service_subdomain" variable
2022/09/30 00:41:09 [emerg] 1507#1507: unknown "cpanel_service_subdomain" variable
2022/09/30 00:54:14 [emerg] 1507#1507: unknown "cpanel_service_subdomain" variable
Upgrade was applied during the automatic nightly upgrade, and outage on sites just woke me up

Code:
[[email protected] log]# yum history info 409
Loaded plugins: fastestmirror, universal-hooks, versionlock
Transaction ID : 409
Begin time     : Fri Sep 30 00:39:57 2022
Begin rpmdb    : 2005:e6ce18f72d7386871e3fed441f116369a651e2c9
End time       :            00:40:26 2022 (29 seconds)
End rpmdb      : 2005:b30566be5ed442ca4371f2d5ef8493d44049758d
User           : root <root>
Return-Code    : Success
Command Line   : --assumeyes --color=never --config /etc/yum.conf update --enablerepo=epel
Transaction performed with:
    Installed     rpm-4.11.3-48.el7_9.x86_64                      @updates
    Installed     yum-3.4.3-168.el7.centos.noarch                 @base
    Installed     yum-plugin-fastestmirror-1.1.31-54.el7_8.noarch @updates
Packages Altered:
    Updated cpanel-analytics-1.4.36-1.1.1.cpanel.noarch             @cpanel-plugins
    Update                   1.4.38-1.1.1.cpanel.noarch             @cpanel-plugins
    Updated ea-apache24-config-1.0-185.189.14.cpanel.noarch         @EA4
    Update                     1.0-187.190.1.cpanel.noarch          @EA4
    Updated ea-apache24-config-runtime-1.0-185.189.14.cpanel.noarch @EA4
    Update                             1.0-187.190.1.cpanel.noarch  @EA4
    Updated ea-nginx-1:1.23.1-3.3.4.cpanel.x86_64                   @EA4
    Update           1:1.23.1-5.5.2.cpanel.x86_64                   @EA4
    Updated ea-php80-pear-1.10.12-4.13.42.cpanel.noarch             @EA4
    Update                1.10.12-4.13.43.cpanel.noarch             @EA4
    Updated ea-php80-php-bcmath-8.0.23-1.1.1.cpanel.x86_64          @EA4
    Update                      8.0.23-2.2.1.cpanel.x86_64          @EA4
    Updated ea-php80-php-cli-8.0.23-1.1.1.cpanel.x86_64             @EA4
    Update                   8.0.23-2.2.1.cpanel.x86_64             @EA4
    Updated ea-php80-php-common-8.0.23-1.1.1.cpanel.x86_64          @EA4
    Update                      8.0.23-2.2.1.cpanel.x86_64          @EA4
    Updated ea-php80-php-curl-8.0.23-1.1.1.cpanel.x86_64            @EA4
    Update                    8.0.23-2.2.1.cpanel.x86_64            @EA4
    Updated ea-php80-php-devel-8.0.23-1.1.1.cpanel.x86_64           @EA4
    Update                     8.0.23-2.2.1.cpanel.x86_64           @EA4
    Updated ea-php80-php-exif-8.0.23-1.1.1.cpanel.x86_64            @EA4
    Update                    8.0.23-2.2.1.cpanel.x86_64            @EA4
    Updated ea-php80-php-fileinfo-8.0.23-1.1.1.cpanel.x86_64        @EA4
    Update                        8.0.23-2.2.1.cpanel.x86_64        @EA4
    Updated ea-php80-php-fpm-8.0.23-1.1.1.cpanel.x86_64             @EA4
    Update                   8.0.23-2.2.1.cpanel.x86_64             @EA4
    Updated ea-php80-php-ftp-8.0.23-1.1.1.cpanel.x86_64             @EA4
    Update                   8.0.23-2.2.1.cpanel.x86_64             @EA4
    Updated ea-php80-php-gd-8.0.23-1.1.1.cpanel.x86_64              @EA4
    Update                  8.0.23-2.2.1.cpanel.x86_64              @EA4
    Updated ea-php80-php-gmp-8.0.23-1.1.1.cpanel.x86_64             @EA4
    Update                   8.0.23-2.2.1.cpanel.x86_64             @EA4
    Updated ea-php80-php-iconv-8.0.23-1.1.1.cpanel.x86_64           @EA4
    Update                     8.0.23-2.2.1.cpanel.x86_64           @EA4
    Updated ea-php80-php-litespeed-8.0.23-1.1.1.cpanel.x86_64       @EA4
    Update                         8.0.23-2.2.1.cpanel.x86_64       @EA4
    Updated ea-php80-php-mbstring-8.0.23-1.1.1.cpanel.x86_64        @EA4
    Update                        8.0.23-2.2.1.cpanel.x86_64        @EA4
    Updated ea-php80-php-mysqlnd-8.0.23-1.1.1.cpanel.x86_64         @EA4
    Update                       8.0.23-2.2.1.cpanel.x86_64         @EA4
    Updated ea-php80-php-opcache-8.0.23-1.1.1.cpanel.x86_64         @EA4
    Update                       8.0.23-2.2.1.cpanel.x86_64         @EA4
    Updated ea-php80-php-pdo-8.0.23-1.1.1.cpanel.x86_64             @EA4
    Update                   8.0.23-2.2.1.cpanel.x86_64             @EA4
    Updated ea-php80-php-posix-8.0.23-1.1.1.cpanel.x86_64           @EA4
    Update                     8.0.23-2.2.1.cpanel.x86_64           @EA4
    Updated ea-php80-php-xml-8.0.23-1.1.1.cpanel.x86_64             @EA4
    Update                   8.0.23-2.2.1.cpanel.x86_64             @EA4
    Updated ea-php80-php-zip-8.0.23-1.1.1.cpanel.x86_64             @EA4
    Update                   8.0.23-2.2.1.cpanel.x86_64             @EA4
    Updated ea-ruby27-mod_passenger-6.0.14-1.1.14.cpanel.x86_64     @EA4
    Update                          6.0.15-1.1.1.cpanel.x86_64      @EA4
    Updated ea-ruby27-ruby-wrapper-6.0.14-1.1.14.cpanel.x86_64      @EA4
    Update                         6.0.15-1.1.1.cpanel.x86_64       @EA4
    Updated ea-ruby27-rubygem-passenger-6.0.14-1.1.14.cpanel.x86_64 @EA4
    Update                              6.0.15-1.1.1.cpanel.x86_64  @EA4
Scriptlet output:
   1 Has existing python configuration, will leave that as is …
   2 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api1::Htaccess::del_user in hooks registry
   3 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api1::Htaccess::set_index in hooks registry
   4 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api1::Htaccess::set_pass in hooks registry
   5 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api1::Htaccess::set_protect in hooks registry
   6 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api1::Park::park in hooks registry
   7 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api1::Park::unpark in hooks registry
   8 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api2::AddonDomain::addaddondomain in hooks registry
   9 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api2::AddonDomain::deladdondomain in hooks registry
  10 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api2::Park::park in hooks registry
  11 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api2::Park::unpark in hooks registry
  12 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api2::SubDomain::addsubdomain in hooks registry
  13 Deleted hook NginxHooks::_do_adminbin for Cpanel::Api2::SubDomain::delsubdomain in hooks registry
  14 Deleted hook NginxHooks::_do_adminbin for Cpanel::UAPI::LangPHP::php_set_vhost_versions in hooks registry
  15 Deleted hook NginxHooks::_do_adminbin for Cpanel::UAPI::LangPHP::php_ini_set_user_content in hooks registry
  16 Deleted hook NginxHooks::_do_adminbin for Cpanel::UAPI::LangPHP::php_ini_set_user_basic_directives in hooks registry
  17 Deleted hook NginxHooks::_do_adminbin for Cpanel::UAPI::Mime::add_redirect in hooks registry
  18 Deleted hook NginxHooks::_do_adminbin for Cpanel::UAPI::Mime::delete_redirect in hooks registry
  19 Deleted hook NginxHooks::_do_adminbin for Cpanel::UAPI::SSL::delete_ssl in hooks registry
  20 Deleted hook NginxHooks::_do_adminbin for Cpanel::UAPI::SSL::install_ssl in hooks registry
  21 Deleted hook NginxHooks::_do_adminbin for Cpanel::UAPI::SSL::toggle_ssl_redirect_for_domains in hooks registry
  22 Deleted hook NginxHooks::_do_adminbin for Cpanel::UAPI::SubDomain::addsubdomain in hooks registry
  23 Deleted hook NginxHooks::_do_adminbin for Cpanel::UAPI::WordPressInstanceManager::start_scan in hooks registry
  24 Deleted hook NginxHooks::_rebuild_config_all for scripts::build_apache_conf in hooks registry
  25 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_add_rule in hooks registry
  26 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_add_vendor in hooks registry
  27 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_assemble_config_text in hooks registry
  28 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_batch_settings in hooks registry
  29 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_clone_rule in hooks registry
  30 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::ModsecCpanelConf::manipulate in hooks registry
  31 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_deploy_all_rule_changes in hooks registry
  32 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_deploy_rule_changes in hooks registry
  33 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_deploy_settings_changes in hooks registry
  34 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_disable_rule in hooks registry
  35 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_disable_vendor in hooks registry
  36 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_disable_vendor_configs in hooks registry
  37 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_disable_vendor_updates in hooks registry
  38 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_discard_rule_changes in hooks registry
  39 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_edit_rule in hooks registry
  40 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_enable_vendor in hooks registry
  41 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_enable_vendor_configs in hooks registry
  42 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_enable_vendor_updates in hooks registry
  43 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_make_config_active in hooks registry
  44 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_make_config_inactive in hooks registry
  45 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_remove_rule in hooks registry
  46 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_remove_setting in hooks registry
  47 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_remove_vendor in hooks registry
  48 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_set_config_text in hooks registry
  49 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_set_setting in hooks registry
  50 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_undisable_rule in hooks registry
  51 Deleted hook NginxHooks::_rebuild_global for Whostmgr::ModSecurity::modsec_update_vendor in hooks registry
  52 Deleted hook NginxHooks::_modsecurity_user for ModSecurity::adjust_secruleengineoff in hooks registry
  53 Deleted hook NginxHooks::_rebuild_global for scripts::modsec_vendor::add in hooks registry
  54 Deleted hook NginxHooks::_rebuild_global for scripts::modsec_vendor::remove in hooks registry
  55 Deleted hook NginxHooks::_rebuild_global for scripts::modsec_vendor::update in hooks registry
  56 Deleted hook NginxHooks::_rebuild_global for scripts::modsec_vendor::enable in hooks registry
  57 Deleted hook NginxHooks::_rebuild_global for scripts::modsec_vendor::disable in hooks registry
  58 Deleted hook NginxHooks::_rebuild_global for scripts::modsec_vendor::enable_updates in hooks registry
  59 Deleted hook NginxHooks::_rebuild_global for scripts::modsec_vendor::disable_updates in hooks registry
  60 Deleted hook NginxHooks::_rebuild_global for scripts::modsec_vendor::enable_configs in hooks registry
  61 Deleted hook NginxHooks::_rebuild_global for scripts::modsec_vendor::disable_configs in hooks registry
  62 Deleted hook NginxHooks::_rebuild_config_all for Whostmgr::Accounts::Modify in hooks registry
  63 Deleted hook NginxHooks::_rebuild_config_all for Whostmgr::Accounts::Remove in hooks registry
  64 Deleted hook NginxHooks::_rebuild_config_all for Whostmgr::Hostname::change in hooks registry
  65 Deleted hook NginxHooks::_rebuild_config_all for Whostmgr::PipedLogConfiguration in hooks registry
  66 Deleted hook NginxHooks::_rebuild_config_all for Whostmgr::TweakSettings::Basic in hooks registry
  67 Deleted hook NginxHooks::_rebuild_config_all for Whostmgr::TweakSettings::Main in hooks registry
  68 Deleted hook NginxHooks::_rebuild_user for Whostmgr::Accounts::Create in hooks registry
  69 Deleted hook NginxHooks::_rebuild_user for Whostmgr::Accounts::SiteIP::set in hooks registry
  70 Deleted hook NginxHooks::_rebuild_user for Whostmgr::AutoSSL::installssl in hooks registry
  71 Deleted hook NginxHooks::_rebuild_user for Whostmgr::SSL::delssl in hooks registry
  72 Deleted hook NginxHooks::_rebuild_user for Whostmgr::SSL::installssl in hooks registry
  73 Deleted hook NginxHooks::_rebuild_user for Whostmgr::Domain::park in hooks registry
  74 Deleted hook NginxHooks::_rebuild_user for Whostmgr::Domain::unpark in hooks registry
  75 Deleted hook NginxHooks::_possible_php_fpm for Whostmgr::Lang::PHP::set_vhost_versions in hooks registry
  76 Deleted hook NginxHooks::_possible_php_fpm for Whostmgr::Lang::PHP::ini_set_content in hooks registry
  77 Deleted hook NginxHooks::_possible_php_fpm for Whostmgr::Lang::PHP::set_system_default_version in hooks registry
  78 Deleted hook NginxHooks::_possible_php_fpm for Whostmgr::Lang::PHP::ini_set_directives in hooks registry
  79 Deleted hook NginxHooks::_php_fpm_config for scripts::php_fpm_config in hooks registry
  80 Deleted hook NginxHooks::_do_wordpress for Cpanel::Api1::cPAddons::mainpg in hooks registry
  81 Deleted hook NginxHooks::_just_clear_user_cache for Whostmgr::Accounts::suspendacct in hooks registry
  82 Deleted hook NginxHooks::_just_clear_user_cache for Whostmgr::Accounts::unsuspendacct in hooks registry
  83 ---
  84 metadata:
  85   command: set_tweaksetting
  86   reason: OK
  87   result: 1
  88   version: 1
  89 Binary upgrade failed, please check nginx's error.log
  90 … using previous python configuration
  91 The “global passenger defaults” application’s “ruby” value (/opt/cpanel/ea-ruby24/root/usr/libexec/passenger-ruby24) is not executable/does not exist.
  92 The current default, /opt/cpanel/ea-ruby27/root/usr/libexec/passenger-ruby27, will be in effect for the “global passenger defaults” application.
  93 Running (global) “/etc/nginx/ea-nginx/config-scripts/global/config-scripts-global-cloudflare” …
  94 Updated /etc/nginx/conf.d/includes-optional/cloudflare.conf OK
  95 Setting up /etc/nginx/conf.d/users/ajbah.conf …
  96 Setting up /etc/nginx/conf.d/users/alantologia.conf …
  97 Processing alantologia (/home/alantologia)
  98    cPanel password protected directories …
  99 Processing ajbah (/home/ajbah)
100    cPanel password protected directories …
101    cPanel redirects …
102  … done (alantologia).
103    cPanel redirects …
104  … done (ajbah).
105 Setting up /etc/nginx/conf.d/users/matarmatar.conf …
106 Processing matarmatar (/home/matarmatar)
107    cPanel password protected directories …
108    cPanel redirects …
109  … done (matarmatar).
110 Added hook for Cpanel::Api1::Htaccess::del_user to hooks registry
111 Added hook for Cpanel::Api1::Htaccess::set_index to hooks registry
112 Added hook for Cpanel::Api1::Htaccess::set_pass to hooks registry
113 Added hook for Cpanel::Api1::Htaccess::set_protect to hooks registry
114 Added hook for Cpanel::Api1::Park::park to hooks registry
115 Added hook for Cpanel::Api1::Park::unpark to hooks registry
116 Added hook for Cpanel::Api2::AddonDomain::addaddondomain to hooks registry
117 Added hook for Cpanel::Api2::AddonDomain::deladdondomain to hooks registry
118 Added hook for Cpanel::Api2::Park::park to hooks registry
119 Added hook for Cpanel::Api2::Park::unpark to hooks registry
120 Added hook for Cpanel::Api2::SubDomain::addsubdomain to hooks registry
121 Added hook for Cpanel::Api2::SubDomain::delsubdomain to hooks registry
122 Added hook for Cpanel::UAPI::LangPHP::php_set_vhost_versions to hooks registry
123 Added hook for Cpanel::UAPI::LangPHP::php_ini_set_user_content to hooks registry
124 Added hook for Cpanel::UAPI::LangPHP::php_ini_set_user_basic_directives to hooks registry
125 Added hook for Cpanel::UAPI::Mime::add_redirect to hooks registry
126 Added hook for Cpanel::UAPI::Mime::delete_redirect to hooks registry
127 Added hook for Cpanel::UAPI::SSL::delete_ssl to hooks registry
128 Added hook for Cpanel::UAPI::SSL::install_ssl to hooks registry
129 Added hook for Cpanel::UAPI::SSL::toggle_ssl_redirect_for_domains to hooks registry
130 Added hook for Cpanel::UAPI::SubDomain::addsubdomain to hooks registry
131 Added hook for Cpanel::UAPI::WordPressInstanceManager::start_scan to hooks registry
132 Added hook for scripts::build_apache_conf to hooks registry
133 Added hook for Whostmgr::ModSecurity::modsec_add_rule to hooks registry
134 Added hook for Whostmgr::ModSecurity::modsec_add_vendor to hooks registry
135 Added hook for Whostmgr::ModSecurity::modsec_assemble_config_text to hooks registry
136 Added hook for Whostmgr::ModSecurity::modsec_batch_settings to hooks registry
137 Added hook for Whostmgr::ModSecurity::modsec_clone_rule to hooks registry
138 Added hook for Whostmgr::ModSecurity::ModsecCpanelConf::manipulate to hooks registry
139 Added hook for Whostmgr::ModSecurity::modsec_deploy_all_rule_changes to hooks registry
140 Added hook for Whostmgr::ModSecurity::modsec_deploy_rule_changes to hooks registry
141 Added hook for Whostmgr::ModSecurity::modsec_deploy_settings_changes to hooks registry
142 Added hook for Whostmgr::ModSecurity::modsec_disable_rule to hooks registry
143 Added hook for Whostmgr::ModSecurity::modsec_disable_vendor to hooks registry
144 Added hook for Whostmgr::ModSecurity::modsec_disable_vendor_configs to hooks registry
145 Added hook for Whostmgr::ModSecurity::modsec_disable_vendor_updates to hooks registry
146 Added hook for Whostmgr::ModSecurity::modsec_discard_rule_changes to hooks registry
147 Added hook for Whostmgr::ModSecurity::modsec_edit_rule to hooks registry
148 Added hook for Whostmgr::ModSecurity::modsec_enable_vendor to hooks registry
149 Added hook for Whostmgr::ModSecurity::modsec_enable_vendor_configs to hooks registry
150 Added hook for Whostmgr::ModSecurity::modsec_enable_vendor_updates to hooks registry
151 Added hook for Whostmgr::ModSecurity::modsec_make_config_active to hooks registry
152 Added hook for Whostmgr::ModSecurity::modsec_make_config_inactive to hooks registry
153 Added hook for Whostmgr::ModSecurity::modsec_remove_rule to hooks registry
154 Added hook for Whostmgr::ModSecurity::modsec_remove_setting to hooks registry
155 Added hook for Whostmgr::ModSecurity::modsec_remove_vendor to hooks registry
156 Added hook for Whostmgr::ModSecurity::modsec_set_config_text to hooks registry
157 Added hook for Whostmgr::ModSecurity::modsec_set_setting to hooks registry
158 Added hook for Whostmgr::ModSecurity::modsec_undisable_rule to hooks registry
159 Added hook for Whostmgr::ModSecurity::modsec_update_vendor to hooks registry
160 Added hook for ModSecurity::adjust_secruleengineoff to hooks registry
161 Added hook for scripts::modsec_vendor::add to hooks registry
162 Added hook for scripts::modsec_vendor::remove to hooks registry
163 Added hook for scripts::modsec_vendor::update to hooks registry
164 Added hook for scripts::modsec_vendor::enable to hooks registry
165 Added hook for scripts::modsec_vendor::disable to hooks registry
166 Added hook for scripts::modsec_vendor::enable_updates to hooks registry
167 Added hook for scripts::modsec_vendor::disable_updates to hooks registry
168 Added hook for scripts::modsec_vendor::enable_configs to hooks registry
169 Added hook for scripts::modsec_vendor::disable_configs to hooks registry
170 Added hook for Whostmgr::Accounts::Modify to hooks registry
171 Added hook for Whostmgr::Accounts::Remove to hooks registry
172 Added hook for Whostmgr::Hostname::change to hooks registry
173 Added hook for Whostmgr::PipedLogConfiguration to hooks registry
174 Added hook for Whostmgr::TweakSettings::Basic to hooks registry
175 Added hook for Whostmgr::TweakSettings::Main to hooks registry
176 Added hook for Whostmgr::Accounts::Create to hooks registry
177 Added hook for Whostmgr::Accounts::SiteIP::set to hooks registry
178 Added hook for Whostmgr::AutoSSL::installssl to hooks registry
179 Added hook for Whostmgr::SSL::delssl to hooks registry
180 Added hook for Whostmgr::SSL::installssl to hooks registry
181 Added hook for Whostmgr::Domain::park to hooks registry
182 Added hook for Whostmgr::Domain::unpark to hooks registry
183 Added hook for Whostmgr::Lang::PHP::set_vhost_versions to hooks registry
184 Added hook for Whostmgr::Lang::PHP::ini_set_content to hooks registry
185 Added hook for Whostmgr::Lang::PHP::set_system_default_version to hooks registry
186 Added hook for Whostmgr::Lang::PHP::ini_set_directives to hooks registry
187 Added hook for scripts::php_fpm_config to hooks registry
188 Added hook for Cpanel::Api1::cPAddons::mainpg to hooks registry
189 Added hook for Whostmgr::Accounts::suspendacct to hooks registry
190 Added hook for Whostmgr::Accounts::unsuspendacct to hooks registry
191 Starting nginx …
192 Unable to ensure a valid nginx configuration:
193
194 nginx: [emerg] unknown "cpanel_service_subdomain" variable
195 nginx: configuration file /etc/nginx/nginx.conf test failed
196
197
198 You will need to manually resolve this issue.
199 Waiting on nginx to come up …
200 Starting apache …
201 Waiting for “httpd” to restart gracefully …waiting for “httpd” to initialize ………finished.
202
203 Service Status
204    httpd (/usr/sbin/httpd -k start) is running as root with PID 1787 (systemd+/proc check method).
205
206 Startup Log
207    Sep 27 14:13:25 host.matarmatar.net systemd[1]: Starting Apache web server managed by cPanel EasyApache...
208    Sep 27 14:13:30 host.matarmatar.net systemd[1]: Can't open PID file /run/apache2/httpd.pid (yet?) after start: No such file or directory
209    Sep 27 14:13:30 host.matarmatar.net systemd[1]: Started Apache web server managed by cPanel EasyApache.
210
211 Log Messages
212    [Tue Sep 27 14:13:30.806518 2022] [mpm_prefork:notice] [pid 1787] AH00163: Apache/2.4.54 (cPanel) OpenSSL/1.1.1q mod_bwlimited/1.4 Phusion_Passenger/6.0.14 configured -- resuming normal operations
213
214 httpd restarted successfully.
215 … done
history info
 
Last edited by a moderator:
  • Like
Reactions: vytas and nasthik

maisondasilva

Active Member
Feb 17, 2009
37
2
58
Brazil
Same here after update for 106.0.8

-- Unit nginx.service has begun starting up.
Sep 29 22:06:42 XXXXXXX nginx[23553]: nginx: [emerg] unknown "cpanel_service_subdomain" variable
Sep 29 22:06:42 XXXXXXX systemd[1]: nginx.service: control process exited, code=exited status=1
Sep 29 22:06:42 XXXXXXX systemd[1]: Failed to start nginx - high performance web server.
-- Subject: Unit nginx.service has failed
-- Defined-By: systemd
-- Support: systemd-devel Info Page
--
-- Unit nginx.service has failed.
--
-- The result is failed.
Sep 29 22:06:42 XXXXXXX systemd[1]: Unit nginx.service entered failed state.
Sep 29 22:06:42 XXXXXXX systemd[1]: nginx.service failed.
 

danfbach

Member
Jan 14, 2021
20
3
3
United States
cPanel Access Level
Root Administrator
As you all know, It's looking for the variable "cpanel_service_subdomain."
It looks like the variable is being declared here ./nginx/ea-nginx/server.conf.tt: set $CPANEL_SERVICE_SUBDOMAIN 1;
So i'm just trying to find where I can either inject that declaration earlier, or remove the invalid reference.
 

danfbach

Member
Jan 14, 2021
20
3
3
United States
cPanel Access Level
Root Administrator
interesting that they suggest enabling service subdomains because my servers already have that enabled and was enabled at the time the update ran and they still crashed...
anyway, not really a problem after the downgrade.
 

Umang Parekh

Member
Feb 21, 2017
5
0
51
India
cPanel Access Level
DataCenter Provider
Yum downgrade works only with cPanel running on CentOS platform. Ubuntu still faces the similar issues

Following worked for UBUNTU versions
==
apt remove ea-nginx
apt install ea-nginx=1.23.1-3+3.2.cpanel
/scripts/ea-nginx config --all
 
Last edited:

Thimempapa

Registered
Oct 4, 2022
2
0
1
Germany
cPanel Access Level
Root Administrator
I´m Trying to install a new machine and get similar error when restarting service.
Nginx appears not to run.
It´s fresh install on centOS7.9
:

Error: [2022-10-04 16:22:05 +0200] info [restartsrv_nginx] systemd failed to start the service “nginx” (The “/usr/bin/systemctl restart nginx.service --no-ask-password” command (process 2843) reported error number 1 when it ended.): Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details. Waiting for “nginx” to start ………failed. Cpanel::Exception::Services::StartError Service Status undefined status from Cpanel::ServiceManager::Services::Nginx Service Error (XID 4pb5hw) The “nginx” service failed to start. Startup Log Oct 04 16:22:05 20-157-97-74.cprapid.com systemd[1]: Starting nginx - high performance web server... Oct 04 16:22:05 20-157-97-74.cprapid.com nginx[2844]: nginx: [emerg] unknown "cpanel_service_subdomain" variable Oct 04 16:22:05 20-157-97-74.cprapid.com systemd[1]: nginx.service: control process exited, code=exited status=1 Oct 04 16:22:05 20-157-97-74.cprapid.com systemd[1]: Failed to start nginx - high performance web server. Oct 04 16:22:05 20-157-97-74.cprapid.com systemd[1]: Unit nginx.service entered failed state. Oct 04 16:22:05 20-157-97-74.cprapid.com systemd[1]: nginx.service failed. Log Messages Oct 4 16:22:05 20-157-97-74 nginx: nginx: [emerg] unknown "cpanel_service_subdomain" variable nginx has failed. Contact your system administrator if the service does not automagically recover.
 

flashweb

Well-Known Member
Mar 13, 2003
256
2
168
cPanel Access Level
Root Administrator
I run

/scripts/upcp --force

nginx still failing, but different error now

nginx: [emerg] invalid number of arguments in "client_max_body_size" directive in /etc/nginx/conf.d/ea-nginx.conf:19