Status
Not open for further replies.

xanubi

Well-Known Member
Jun 28, 2006
86
2
158
The Main >> Server Status >> Apache Status is not working after install.
Is there is any way so we can view apache status in root whm?
Edit /usr/local/apache/conf/httpd.conf

FIND:
<Location /whm-server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Location>

ADD YOUR SERVER MAIN IP ADDRESS:
<Location /whm-server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 127.0.0.1
Allow from YOUR-MAIN-IP-ADDRESS-HERE
</Location>
 

9xlinux

Well-Known Member
Verifed Vendor
Dec 20, 2009
185
0
66
cPanel Access Level
Root Administrator
Edit /usr/local/apache/conf/httpd.conf

FIND:
<Location /whm-server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Location>

ADD YOUR SERVER MAIN IP ADDRESS:
<Location /whm-server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 127.0.0.1
Allow from YOUR-MAIN-IP-ADDRESS-HERE
</Location>
I have tried it but not working.
 

9xlinux

Well-Known Member
Verifed Vendor
Dec 20, 2009
185
0
66
cPanel Access Level
Root Administrator
Below the change I made,

<Location /whm-server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 127.0.0.1
Allow from xx.xx.xx.xx (My main ip)
</Location>

The status is showing via command 'service httpd status' but not showing via whm >> Server Status >> Apache Status
The whm is displaying error below,
Failed to receive status information from Apache.

yes I have restart apache many times after edit.
 
Last edited:

xanubi

Well-Known Member
Jun 28, 2006
86
2
158
Below the change I made,

<Location /whm-server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 127.0.0.1
Allow from xx.xx.xx.xx (My main ip)
</Location>

The status is showing via command 'service httpd status' but not showing via whm >> Server Status >> Apache Status
The whm is displaying error below,
Failed to receive status information from Apache.

yes I have restart apache many times after edit.
Just for clarification, you've put the ip format, like this example, right?:
Allow from 192.168.2.169

Also, did you make all the changes described in this post:
http://forums.cpanel.net/f5/nginx-automated-installer-148109.html#post629597
 

9xlinux

Well-Known Member
Verifed Vendor
Dec 20, 2009
185
0
66
cPanel Access Level
Root Administrator
Just for clarification, you've put the ip format, like this example, right?:
Allow from 192.168.2.169

Also, did you make all the changes described in this post:
http://forums.cpanel.net/f5/nginx-automated-installer-148109.html#post629597
Yes, I have use same format as below example below,
Allow from 192.168.2.169

all the changes described in this post:
http://forums.cpanel.net/f5/nginx-automated-installer-148109.html#post629597 are already done by default by installer.( I have verified)
But apache status is still not showing in whm.
 

xanubi

Well-Known Member
Jun 28, 2006
86
2
158
Yes, I have use same format as below example below,
Allow from 192.168.2.169

all the changes described in this post:
http://forums.cpanel.net/f5/nginx-automated-installer-148109.html#post629597 are already done by default by installer.( I have verified)
But apache status is still not showing in whm.
well, without seeing inside the server, at this point is impossible to know what's the problem is. For sure, there is something that is not correct, but without inside analisys, i cannot guess nothing more.

Try to review all the parameters. By the way, what is the error that the apache status give you?
 

blargman

Well-Known Member
Verifed Vendor
Sep 11, 2007
99
0
56
Run the uninstall and make sure you have the latest version and rerun the installer and let me know.
 

blargman

Well-Known Member
Verifed Vendor
Sep 11, 2007
99
0
56
You can ignore that. That is a remnant of an internal release I have for work here that has a few things that the public release doesn't need. I've removed it from the latest public release. I'm working on fixing the whm-server-status issue as well. **edit** I should say I'm going to add the public ip to the allow by default. I'm sorry but I still am not sure what your issue is. It should be working.
 

9xlinux

Well-Known Member
Verifed Vendor
Dec 20, 2009
185
0
66
cPanel Access Level
Root Administrator
You can ignore that. That is a remnant of an internal release I have for work here that has a few things that the public release doesn't need. I've removed it from the latest public release. I'm working on fixing the whm-server-status issue as well. **edit** I should say I'm going to add the public ip to the allow by default. I'm sorry but I still am not sure what your issue is. It should be working.
I have uninstalled and reinstalled but same issue. update when you upgrade script so I can try again with latest release.
 
Last edited:

blargman

Well-Known Member
Verifed Vendor
Sep 11, 2007
99
0
56
No problem, I'm trying to pin down exactly what url Cpanel is trying to get. It's pulling up an odd vhost on my machine when it connects instead of the hostname. Though really adding allow from all should fix it regardless of what I do regarding the auto-installation.
 

Echelon17

Well-Known Member
May 21, 2006
73
0
156
Very nice package, great job :) I've noticed 2 issues though:

1. An "uninstall" doesn't quite uninstall everything and revert it back to normal. As an example, all of the files in /var/cpanel/userdata/* still contain references to port 8081. For cleanliness, I'd strongly recommend completely mirroring the installation process and reverting everything *properly* ;)

2. Not sure why, but on one of the servers I tried I get the following error:

Code:
Traceback (most recent call last):
  File "./createvhosts.py", line 159, in ?
    if len(sublist) != 0:
TypeError: len() of unsized object
Same python version as 2 other servers that it worked fine on. Checked the python code and presumably it's a bug?
 

icodex

Member
Feb 24, 2010
10
0
51
about client's real IP.

I found a problem and i wanna give you some suggestions.

apache cannot obtain the client's real IP, because mod_rpaf module cannot be loaded after rebuildhttpdconf and rpaf.conf misses a value.

on file:/usr/local/src/publicnginx/nginxinstaller

code in the 10 to 30 lines:

change /usr/local/apache/conf/httpd.conf to /usr/local/apache/conf/includes/pre_main_global.conf

on file:/usr/local/src/publicnginx/nginxinstaller2

red line is addon.

rpafinclude = """cat >> "/usr/local/apache/conf/includes/rpaf.conf" <<EOF
LoadModule rpaf_module modules/mod_rpaf-2.0.so
#Mod_rpaf settings
RPAFenable On
RPAFproxy_ips 127.0.0.1 %s
RPAFsethostname On
RPAFheader X-Forwarded-For
EOF""" % (ipliststring)

via:iCodex

I hope next update can support some useful functions such as 'Password Protect Directories' 'HotLink Protection' ...
 
Last edited:

blargman

Well-Known Member
Verifed Vendor
Sep 11, 2007
99
0
56
icodex, I can add the extra header though any issues with rebuildhttpdconf should be resolved. I had some issues with the uninstall/install not removing/adding the rpaf line properly. Make sure you are running the latest version as of late yesterday. ( I probably should version these sorry,bugs seem to always be plentiful and I'm fairly quick to fix them)


Echelon, the script doesn't modify userdata files at all. It does modify the apache port in /var/cpanel/cpanel.config and tweak settings goes through and updates all the userdata files. If you are still seeing userdata files with 8081 as the port, perhaps tweaksettings didn't finish for some reason or failed in some way. Try removing
on line 70:

> /dev/null 2>&1

The sublist issue you are seeing is one I have seem before but I had added checks to fix it. I'll have to do some testing to try and reproduce it. I think you'l lfind one of your userdata/main files has a subdomain etnry with no [].
 

xanubi

Well-Known Member
Jun 28, 2006
86
2
158
icodex, I can add the extra header though any issues with rebuildhttpdconf should be resolved. I had some issues with the uninstall/install not removing/adding the rpaf line properly. Make sure you are running the latest version as of late yesterday. ( I probably should version these sorry,bugs seem to always be plentiful and I'm fairly quick to fix them)


Echelon, the script doesn't modify userdata files at all. It does modify the apache port in /var/cpanel/cpanel.config and tweak settings goes through and updates all the userdata files. If you are still seeing userdata files with 8081 as the port, perhaps tweaksettings didn't finish for some reason or failed in some way. Try removing
on line 70:

> /dev/null 2>&1

The sublist issue you are seeing is one I have seem before but I had added checks to fix it. I'll have to do some testing to try and reproduce it. I think you'l lfind one of your userdata/main files has a subdomain etnry with no [].
In the latest update, when the script runs nginxinstaller2, the script crashes with ":no such directory exists"
 

blargman

Well-Known Member
Verifed Vendor
Sep 11, 2007
99
0
56
icodex - good idea, never use it really so didn't think of it. I'll see if there is a hook. If there is one I'll add it.
 
Status
Not open for further replies.