Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Nginx proxy not able to display squirrelmail

Discussion in 'E-mail Discussion' started by Anoop P Alias, Jun 15, 2018.

  1. Anoop P Alias

    Anoop P Alias Well-Known Member

    Joined:
    Mar 31, 2015
    Messages:
    94
    Likes Received:
    14
    Trophy Points:
    8
    Location:
    Kochi,Kerala,India
    cPanel Access Level:
    Root Administrator
    Running Nginx as a reverse proxy, webmail like Horde and Squirrelmail fail to display

    Because of the webmail.php use header as below

    i.imgur.com/SyVyI8t.png


    i.imgur.com/p8lbeZr.png

    This popped up in a recent upgrade I believe

    Ref: github.com/engintron/engintron/issues/864
    Webmail not working · Issue #864 · engintron/engintron
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 Anoop P Alias, Jun 15, 2018
    Last edited by a moderator: Jun 15, 2018
  2. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    250
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Anoop P Alias

    nginx and engintron are 3rd party software and not something supported by cPanel at this time. If there's an issue with this we can recommend that you switch back to Apache to determine if the issue is still present but issues with displaying pages over nginx need to be addressed with the maker of the plugin.

    Looking at the link to the report you provided from engintron's GitHub it does appear that switching back to apache resolves the issue in this instance. Furthermore I want to point out that SquirrelMail is going away The Death of SquirrelMail | cPanel Blog and it will be removed from the product in a future release.

    You might take a look at WHM>>Server Configuration>>Tweak Settings ->
    Use X-Frame-Options and X-Content-Type-Options headers with cpsrvd
    And toggle the setting - I'm not sure this would resolve the issue but may be worth looking at.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice