Nginx stoped working after last updates

Spirogg

Well-Known Member
Feb 21, 2018
696
151
43
chicago
cPanel Access Level
Root Administrator
maybe your BaseOS repo is not a good source for update httpd
you can check with mine below and see if it is the same ?

[baseos]
name=AlmaLinux $releasever - BaseOS
mirrorlist=https://mirrors.almalinux.org/mirrorlist/$releasever/baseos
# baseurl=https://repo.almalinux.org/almalinux/$releasever/BaseOS/$basearch/os/
enabled=1
gpgcheck=1
countme=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux


Code:
[[email protected] yum.repos.d]# cat almalinux.repo
# almalinux.repo

[baseos]
name=AlmaLinux $releasever - BaseOS
mirrorlist=https://mirrors.almalinux.org/mirrorlist/$releasever/baseos
# baseurl=https://repo.almalinux.org/almalinux/$releasever/BaseOS/$basearch/os/
enabled=1
gpgcheck=1
countme=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux

[appstream]
name=AlmaLinux $releasever - AppStream
mirrorlist=https://mirrors.almalinux.org/mirrorlist/$releasever/appstream
# baseurl=https://repo.almalinux.org/almalinux/$releasever/AppStream/$basearch/os/
enabled=1
gpgcheck=1
countme=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux

[extras]
name=AlmaLinux $releasever - Extras
mirrorlist=https://mirrors.almalinux.org/mirrorlist/$releasever/extras
# baseurl=https://repo.almalinux.org/almalinux/$releasever/extras/$basearch/os/
enabled=1
gpgcheck=1
countme=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux

## Sources
[baseos-source]
name=AlmaLinux $releasever - BaseOS Source
mirrorlist=https://mirrors.almalinux.org/mirrorlist/$releasever/baseos-source
# baseurl=https://repo.almalinux.org/almalinux/$releasever/BaseOS/Source/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux

[appstream-source]
name=AlmaLinux $releasever - AppStream Source
mirrorlist=https://mirrors.almalinux.org/mirrorlist/$releasever/appstream-source
# baseurl=https://repo.almalinux.org/almalinux/$releasever/AppStream/Source/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux

[extras-source]
name=AlmaLinux $releasever - Extras Source
mirrorlist=https://mirrors.almalinux.org/mirrorlist/$releasever/extras-source
# baseurl=https://repo.almalinux.org/almalinux/$releasever/extras/Source/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux

## Debuginfo
[baseos-debuginfo]
name=AlmaLinux $releasever - BaseOS debuginfo
mirrorlist=https://mirrors.almalinux.org/mirrorlist/$releasever/baseos-debuginfo
# baseurl=https://repo.almalinux.org/almalinux/$releasever/BaseOS/debug/$basearch/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux

[appstream-debuginfo]
name=AlmaLinux $releasever - AppStream debuginfo
mirrorlist=https://mirrors.almalinux.org/mirrorlist/$releasever/appstream-debuginfo
# baseurl=https://repo.almalinux.org/almalinux/$releasever/AppStream/debug/$basearch/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux

[extras-debuginfo]
name=AlmaLinux $releasever - Extras debuginfo
mirrorlist=https://mirrors.almalinux.org/mirrorlist/$releasever/extras-debuginfo
# baseurl=https://repo.almalinux.org/almalinux/$releasever/extras/debug/$basearch/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
maybe where you host your server / vps they have there own repos and are older ?
because when I rum yum install httpd I get this below
Code:
[[email protected] /]# yum install httpd
Last metadata expiration check: 0:16:11 ago on Sat 30 Apr 2022 04:20:41 PM CDT.
Error:
 Problem: problem with installed package ea-apache24-2.4.53-2.2.1.cpanel.x86_64
  - package ea-apache24-2.4.53-2.2.1.cpanel.x86_64 conflicts with httpd-mmn provided by httpd-2.4.37-43.module_el8.5.0+2631+6f259f31.3.alma.x86_64
  - package ea-apache24-2.4.52-3.3.6.cpanel.x86_64 conflicts with httpd-mmn provided by httpd-2.4.37-43.module_el8.5.0+2631+6f259f31.3.alma.x86_64
  - package ea-apache24-2.4.52-3.3.7.cpanel.x86_64 conflicts with httpd-mmn provided by httpd-2.4.37-43.module_el8.5.0+2631+6f259f31.3.alma.x86_64
  - package ea-apache24-2.4.53-1.1.7.cpanel.x86_64 conflicts with httpd-mmn provided by httpd-2.4.37-43.module_el8.5.0+2631+6f259f31.3.alma.x86_64
  - package ea-apache24-2.4.53-1.1.8.cpanel.x86_64 conflicts with httpd-mmn provided by httpd-2.4.37-43.module_el8.5.0+2631+6f259f31.3.alma.x86_64
  - cannot install the best candidate for the job
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[[email protected] /]#
same thing if i try dnf install httpd

Code:
[[email protected] /]# dnf install httpd
Last metadata expiration check: 0:17:37 ago on Sat 30 Apr 2022 04:20:41 PM CDT.
Error:
 Problem: problem with installed package ea-apache24-2.4.53-2.2.1.cpanel.x86_64
  - package ea-apache24-2.4.53-2.2.1.cpanel.x86_64 conflicts with httpd-mmn provided by httpd-2.4.37-43.module_el8.5.0+2631+6f259f31.3.alma.x86_64
  - package ea-apache24-2.4.52-3.3.6.cpanel.x86_64 conflicts with httpd-mmn provided by httpd-2.4.37-43.module_el8.5.0+2631+6f259f31.3.alma.x86_64
  - package ea-apache24-2.4.52-3.3.7.cpanel.x86_64 conflicts with httpd-mmn provided by httpd-2.4.37-43.module_el8.5.0+2631+6f259f31.3.alma.x86_64
  - package ea-apache24-2.4.53-1.1.7.cpanel.x86_64 conflicts with httpd-mmn provided by httpd-2.4.37-43.module_el8.5.0+2631+6f259f31.3.alma.x86_64
  - package ea-apache24-2.4.53-1.1.8.cpanel.x86_64 conflicts with httpd-mmn provided by httpd-2.4.37-43.module_el8.5.0+2631+6f259f31.3.alma.x86_64
  - cannot install the best candidate for the job
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[[email protected] /]#
also httpd and httpd -v
Code:
[[email protected] /]# httpd
httpd (pid 1888) already running
[[email protected] /]# httpd -v
Server version: Apache/2.4.53 (cPanel)
Server built:   Apr 19 2022 23:38:52
[[email protected] /]#
 

Spirogg

Well-Known Member
Feb 21, 2018
696
151
43
chicago
cPanel Access Level
Root Administrator

AlphaPrime

Active Member
Aug 23, 2021
42
6
8
Romania
cPanel Access Level
Root Administrator
what is the output of:

cat /etc/yum.repos.d/EA4.repo
cat /etc/redhat-release



this is my EA4.repo
Code:
[[email protected] yum.repos.d]# cat EA4.repo
[EA4]
name=EA4 ( EasyApache 4 )
mirrorlist=http://httpupdate.cpanel.net/ea4-c$releasever-$basearch-mirrorlist
gpgcheck=1
gpgkey=https://securedownloads.cpanel.net/cPanelPublicPkgKey.asc
enabled=1
cost=50
[[email protected] yum.repos.d]# cat /etc/redhat-release
AlmaLinux release 8.5 (Arctic Sphynx)
[[email protected] ~]# cat /etc/yum.repos.d/EA4.repo
[EA4]
name=EA4 ( EasyApache 4 )
mirrorlist=http://httpupdate.cpanel.net/ea4-c$releasever-$basearch-mirrorlist
gpgcheck=1
gpgkey=https://securedownloads.cpanel.net/cPanelPublicRPMKey.asc
enabled=1
cost=50
[[email protected] ~]# cat /etc/redhat-release
CentOS Linux release 7.9.2009 (Core)
[[email protected] ~]#
 

AlphaPrime

Active Member
Aug 23, 2021
42
6
8
Romania
cPanel Access Level
Root Administrator
@AlphaPrime

i didnt think of this did you try installing apache ?

yum install ea-apache24
yum install ea-apache24
Loaded plugins: fastestmirror, universal-hooks, versionlock
Loading mirror speeds from cached hostfile
* EA4: 93.115.203.100
* cpanel-addons-production-feed: 93.115.203.100
* cpanel-plugins: 93.115.203.100
* base: mirrors.m247.ro
* centos-sclo-rh: mirrors.nav.ro
* centos-sclo-sclo: mirrors.nav.ro
* epel: mirrors.nav.ro
* extras: mirrors.m247.ro
* remi: mirrors.netix.net
* remi-safe: mirrors.netix.net
* updates: mirrors.m247.ro
varnish60lts/signature | 833 B 00:00:00
varnish60lts/signature | 1.8 kB 00:00:04 !!!
Resolving Dependencies
--> Running transaction check
---> Package ea-apache24.x86_64 0:2.4.53-2.2.1.cpanel will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================================================================================================
Package Arch Version Repository Size
=====================================================================================================================================================================================================================================
Installing:
ea-apache24 x86_64 2.4.53-2.2.1.cpanel EA4 2.3 M

Transaction Summary
=====================================================================================================================================================================================================================================
Install 1 Package

Total download size: 2.3 M
Installed size: 8.1 M
Is this ok [y/d/N]: y
Downloading packages:
ea-apache24-2.4.53-2.2.1.cpanel.x86_64.rpm | 2.3 MB 00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
usermod: no changes
Installing : ea-apache24-2.4.53-2.2.1.cpanel.x86_64 1/1
Error unpacking rpm package ea-apache24-2.4.53-2.2.1.cpanel.x86_64
warning: /etc/apache2/conf/httpd.conf created as /etc/apache2/conf/httpd.conf.rpmnew
warning: /etc/apache2/conf/mime.types created as /etc/apache2/conf/mime.types.rpmnew
error: unpacking of archive failed on file /etc/apache2/logs: cpio: rename
usermod: no changes
info [009-phpconf] Could not find a handler for ea-php74. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php80. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php81. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php74. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php80. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php81. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
die [009-phpconf] Cpanel::Exception::FeatureNotEnabled/(XID e2d8q3) The following modules are required for handler “cgi”: mod_cgi or mod_cgid
exit level [die] [pid=63575] (Cpanel::Exception::FeatureNotEnabled/(XID e2d8q3) The following modules are required for handler “cgi”: mod_cgi or mod_cgid)
!!!! "/etc/yum/universal-hooks/multi_pkgs/posttrans/ea-__WILDCARD__/009-phpconf.pl --pkg_list=/tmp/tmpFjsnMd" did not exit cleanly: 65280
Purging all relevant cached command results
Rebuilding global cache
Building global cache for cpanel...Done
Nothing to do (/etc/suphp.conf does not exist)
info [modsec_cpanel_conf_init] The modsec2.cpanel.conf file and its datastore are already set up. No further action is required.
Unable to detect Apache version from binary
!!!! "/etc/yum/universal-hooks/multi_pkgs/posttrans/ea-__WILDCARD__/020-rebuild-httpdconf --pkg_list=/tmp/tmpFjsnMd" did not exit cleanly: 65280
Nothing to do under ea4 (this script has been deprecated under ea4).
Fix mailman package directories …
… PID 63595
Fix mailing list perms …
… PID 63597
Aligning modsec config to Whostmgr
- Whostmgr version 11.102.0.12
- Whostmgr supports conf.d/modsec location
- No change necessary
warn [restartsrv_httpd] The system is unable to find systemd configuration for the 'httpd' service...
Service “httpd” is already stopped.

Log Messages
May 1 03:41:36 hosting yum[63516]: ea-apache24-2.4.53-2.2.1.cpanel.x86_64: 100

httpd stopped successfully.
warn [restartsrv_httpd] The system is unable to find systemd configuration for the 'httpd' service...
Cpanel::Exception::Service::BinaryNotFound
Service Status
undefined status from Cpanel::ServiceManager::Services::Httpd

Service Error
(XID 27gbzg) The system could not find the “/usr/sbin/apachectl” binary for the “httpd” service because of an error: No such file or directory

Log Messages
May 1 03:41:36 hosting yum[63516]: ea-apache24-2.4.53-2.2.1.cpanel.x86_64: 100

httpd has failed. Contact your system administrator if the service does not automagically recover.
Setting /home permissions to 0711 …
Setting permissions for users …
crowdswaas …
synergymarkets …
tehnos …
suzanabanuc …
synergyf …
ramira …
lusatinadmin …
masajholisticgal …
startuplab …
royalgfcstyle …
medigalhouse …
alphaprime …
stagiipra …
orientari …
cebuphi …
stagiipractica …
… Done
Verifying : ea-apache24-2.4.53-2.2.1.cpanel.x86_64 1/1

Failed:
ea-apache24.x86_64 0:2.4.53-2.2.1.cpanel

Complete!

This is the big problem... i have an error when I try to install it!

<<<<<
warn [restartsrv_httpd] The system is unable to find systemd configuration for the 'httpd' service...
Cpanel::Exception::Service::BinaryNotFound
Service Status
undefined status from Cpanel::ServiceManager::Services::Httpd

Service Error
(XID 27gbzg) The system could not find the “/usr/sbin/apachectl” binary for the “httpd” service because of an error: No such file or directory>>>.
 

Spirogg

Well-Known Member
Feb 21, 2018
696
151
43
chicago
cPanel Access Level
Root Administrator
yum install ea-apache24
Loaded plugins: fastestmirror, universal-hooks, versionlock
Loading mirror speeds from cached hostfile
* EA4: 93.115.203.100
* cpanel-addons-production-feed: 93.115.203.100
* cpanel-plugins: 93.115.203.100
* base: mirrors.m247.ro
* centos-sclo-rh: mirrors.nav.ro
* centos-sclo-sclo: mirrors.nav.ro
* epel: mirrors.nav.ro
* extras: mirrors.m247.ro
* remi: mirrors.netix.net
* remi-safe: mirrors.netix.net
* updates: mirrors.m247.ro
varnish60lts/signature | 833 B 00:00:00
varnish60lts/signature | 1.8 kB 00:00:04 !!!
Resolving Dependencies
--> Running transaction check
---> Package ea-apache24.x86_64 0:2.4.53-2.2.1.cpanel will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================================================================================================
Package Arch Version Repository Size
=====================================================================================================================================================================================================================================
Installing:
ea-apache24 x86_64 2.4.53-2.2.1.cpanel EA4 2.3 M

Transaction Summary
=====================================================================================================================================================================================================================================
Install 1 Package

Total download size: 2.3 M
Installed size: 8.1 M
Is this ok [y/d/N]: y
Downloading packages:
ea-apache24-2.4.53-2.2.1.cpanel.x86_64.rpm | 2.3 MB 00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
usermod: no changes
Installing : ea-apache24-2.4.53-2.2.1.cpanel.x86_64 1/1
Error unpacking rpm package ea-apache24-2.4.53-2.2.1.cpanel.x86_64
warning: /etc/apache2/conf/httpd.conf created as /etc/apache2/conf/httpd.conf.rpmnew
warning: /etc/apache2/conf/mime.types created as /etc/apache2/conf/mime.types.rpmnew
error: unpacking of archive failed on file /etc/apache2/logs: cpio: rename
usermod: no changes
info [009-phpconf] Could not find a handler for ea-php74. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php80. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php81. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php74. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php80. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php81. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
die [009-phpconf] Cpanel::Exception::FeatureNotEnabled/(XID e2d8q3) The following modules are required for handler “cgi”: mod_cgi or mod_cgid
exit level [die] [pid=63575] (Cpanel::Exception::FeatureNotEnabled/(XID e2d8q3) The following modules are required for handler “cgi”: mod_cgi or mod_cgid)
!!!! "/etc/yum/universal-hooks/multi_pkgs/posttrans/ea-__WILDCARD__/009-phpconf.pl --pkg_list=/tmp/tmpFjsnMd" did not exit cleanly: 65280
Purging all relevant cached command results
Rebuilding global cache
Building global cache for cpanel...Done
Nothing to do (/etc/suphp.conf does not exist)
info [modsec_cpanel_conf_init] The modsec2.cpanel.conf file and its datastore are already set up. No further action is required.
Unable to detect Apache version from binary
!!!! "/etc/yum/universal-hooks/multi_pkgs/posttrans/ea-__WILDCARD__/020-rebuild-httpdconf --pkg_list=/tmp/tmpFjsnMd" did not exit cleanly: 65280
Nothing to do under ea4 (this script has been deprecated under ea4).
Fix mailman package directories …
… PID 63595
Fix mailing list perms …
… PID 63597
Aligning modsec config to Whostmgr
- Whostmgr version 11.102.0.12
- Whostmgr supports conf.d/modsec location
- No change necessary
warn [restartsrv_httpd] The system is unable to find systemd configuration for the 'httpd' service...
Service “httpd” is already stopped.

Log Messages
May 1 03:41:36 hosting yum[63516]: ea-apache24-2.4.53-2.2.1.cpanel.x86_64: 100

httpd stopped successfully.
warn [restartsrv_httpd] The system is unable to find systemd configuration for the 'httpd' service...
Cpanel::Exception::Service::BinaryNotFound
Service Status
undefined status from Cpanel::ServiceManager::Services::Httpd

Service Error
(XID 27gbzg) The system could not find the “/usr/sbin/apachectl” binary for the “httpd” service because of an error: No such file or directory

Log Messages
May 1 03:41:36 hosting yum[63516]: ea-apache24-2.4.53-2.2.1.cpanel.x86_64: 100

httpd has failed. Contact your system administrator if the service does not automagically recover.
Setting /home permissions to 0711 …
Setting permissions for users …
crowdswaas …
synergymarkets …
tehnos …
suzanabanuc …
synergyf …
ramira …
lusatinadmin …
masajholisticgal …
startuplab …
royalgfcstyle …
medigalhouse …
alphaprime …
stagiipra …
orientari …
cebuphi …
stagiipractica …
… Done
Verifying : ea-apache24-2.4.53-2.2.1.cpanel.x86_64 1/1

Failed:
ea-apache24.x86_64 0:2.4.53-2.2.1.cpanel

Complete!

This is the big problem... i have an error when I try to install it!

<<<<<
warn [restartsrv_httpd] The system is unable to find systemd configuration for the 'httpd' service...
Cpanel::Exception::Service::BinaryNotFound
Service Status
undefined status from Cpanel::ServiceManager::Services::Httpd

Service Error
(XID 27gbzg) The system could not find the “/usr/sbin/apachectl” binary for the “httpd” service because of an error: No such file or directory>>>.

try running this


/scripts/rpmup
 

Spirogg

Well-Known Member
Feb 21, 2018
696
151
43
chicago
cPanel Access Level
Root Administrator
yum install ea-apache24
Loaded plugins: fastestmirror, universal-hooks, versionlock
Loading mirror speeds from cached hostfile
* EA4: 93.115.203.100
* cpanel-addons-production-feed: 93.115.203.100
* cpanel-plugins: 93.115.203.100
* base: mirrors.m247.ro
* centos-sclo-rh: mirrors.nav.ro
* centos-sclo-sclo: mirrors.nav.ro
* epel: mirrors.nav.ro
* extras: mirrors.m247.ro
* remi: mirrors.netix.net
* remi-safe: mirrors.netix.net
* updates: mirrors.m247.ro
varnish60lts/signature | 833 B 00:00:00
varnish60lts/signature | 1.8 kB 00:00:04 !!!
Resolving Dependencies
--> Running transaction check
---> Package ea-apache24.x86_64 0:2.4.53-2.2.1.cpanel will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================================================================================================
Package Arch Version Repository Size
=====================================================================================================================================================================================================================================
Installing:
ea-apache24 x86_64 2.4.53-2.2.1.cpanel EA4 2.3 M

Transaction Summary
=====================================================================================================================================================================================================================================
Install 1 Package

Total download size: 2.3 M
Installed size: 8.1 M
Is this ok [y/d/N]: y
Downloading packages:
ea-apache24-2.4.53-2.2.1.cpanel.x86_64.rpm | 2.3 MB 00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
usermod: no changes
Installing : ea-apache24-2.4.53-2.2.1.cpanel.x86_64 1/1
Error unpacking rpm package ea-apache24-2.4.53-2.2.1.cpanel.x86_64
warning: /etc/apache2/conf/httpd.conf created as /etc/apache2/conf/httpd.conf.rpmnew
warning: /etc/apache2/conf/mime.types created as /etc/apache2/conf/mime.types.rpmnew
error: unpacking of archive failed on file /etc/apache2/logs: cpio: rename
usermod: no changes
info [009-phpconf] Could not find a handler for ea-php74. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php80. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php81. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php74. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php80. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
info [009-phpconf] Could not find a handler for ea-php81. Defaulting to “cgi” so that, at worst case, we get an error instead of source code.
die [009-phpconf] Cpanel::Exception::FeatureNotEnabled/(XID e2d8q3) The following modules are required for handler “cgi”: mod_cgi or mod_cgid
exit level [die] [pid=63575] (Cpanel::Exception::FeatureNotEnabled/(XID e2d8q3) The following modules are required for handler “cgi”: mod_cgi or mod_cgid)
!!!! "/etc/yum/universal-hooks/multi_pkgs/posttrans/ea-__WILDCARD__/009-phpconf.pl --pkg_list=/tmp/tmpFjsnMd" did not exit cleanly: 65280
Purging all relevant cached command results
Rebuilding global cache
Building global cache for cpanel...Done
Nothing to do (/etc/suphp.conf does not exist)
info [modsec_cpanel_conf_init] The modsec2.cpanel.conf file and its datastore are already set up. No further action is required.
Unable to detect Apache version from binary
!!!! "/etc/yum/universal-hooks/multi_pkgs/posttrans/ea-__WILDCARD__/020-rebuild-httpdconf --pkg_list=/tmp/tmpFjsnMd" did not exit cleanly: 65280
Nothing to do under ea4 (this script has been deprecated under ea4).
Fix mailman package directories …
… PID 63595
Fix mailing list perms …
… PID 63597
Aligning modsec config to Whostmgr
- Whostmgr version 11.102.0.12
- Whostmgr supports conf.d/modsec location
- No change necessary
warn [restartsrv_httpd] The system is unable to find systemd configuration for the 'httpd' service...
Service “httpd” is already stopped.

Log Messages
May 1 03:41:36 hosting yum[63516]: ea-apache24-2.4.53-2.2.1.cpanel.x86_64: 100

httpd stopped successfully.
warn [restartsrv_httpd] The system is unable to find systemd configuration for the 'httpd' service...
Cpanel::Exception::Service::BinaryNotFound
Service Status
undefined status from Cpanel::ServiceManager::Services::Httpd

Service Error
(XID 27gbzg) The system could not find the “/usr/sbin/apachectl” binary for the “httpd” service because of an error: No such file or directory

Log Messages
May 1 03:41:36 hosting yum[63516]: ea-apache24-2.4.53-2.2.1.cpanel.x86_64: 100

httpd has failed. Contact your system administrator if the service does not automagically recover.
Setting /home permissions to 0711 …
Setting permissions for users …
crowdswaas …
synergymarkets …
tehnos …
suzanabanuc …
synergyf …
ramira …
lusatinadmin …
masajholisticgal …
startuplab …
royalgfcstyle …
medigalhouse …
alphaprime …
stagiipra …
orientari …
cebuphi …
stagiipractica …
… Done
Verifying : ea-apache24-2.4.53-2.2.1.cpanel.x86_64 1/1

Failed:
ea-apache24.x86_64 0:2.4.53-2.2.1.cpanel

Complete!

This is the big problem... i have an error when I try to install it!

<<<<<
warn [restartsrv_httpd] The system is unable to find systemd configuration for the 'httpd' service...
Cpanel::Exception::Service::BinaryNotFound
Service Status
undefined status from Cpanel::ServiceManager::Services::Httpd

Service Error
(XID 27gbzg) The system could not find the “/usr/sbin/apachectl” binary for the “httpd” service because of an error: No such file or directory>>>.
one more you can try to update ea4

[[email protected] ~]# /usr/local/cpanel/scripts/sysup
info [sysup] ea4: repo already installed
checkyum version 22.3 (excludes: bind-chroot)
All Needed Packages are already installed.
[[email protected] ~]#
 

Spirogg

Well-Known Member
Feb 21, 2018
696
151
43
chicago
cPanel Access Level
Root Administrator
Support helped me and now I have the httpd back... and php-fpm! All working.
It seams that the problem started with cloudlinux because of imunify360!
I’m glad you got it resolved. Really weird that imunify360 caused this issue ??