NGINX with Reverse Proxy + CloudLinux

AlIur

Member
May 8, 2021
6
0
1
Moscow
cPanel Access Level
Root Administrator
Unfortunately, it is not installed on servers where CloudLinux is installed : (this is the log that is issued:

Installation process started for the NGINX package.


[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-nginx.x86_64 3:1.19.7-3.el7.cloudlinux will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27 for package: 3:ea-nginx-1.19.7-3.el7.cloudlinux.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: apache24-passenger for package: 3:ea-nginx-1.19.7-3.el7.cloudlinux.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-modsec30 for package: 3:ea-nginx-1.19.7-3.el7.cloudlinux.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-modsec30-connector-nginx for package: 3:ea-nginx-1.19.7-3.el7.cloudlinux.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Running transaction check
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-modsec30.x86_64 1:3.0.4-6.el7.cloudlinux will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-modsec30-connector-nginx.x86_64 1:1.0.1-1.el7.cloudlinux will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27.x86_64 1:2.7.2-6.el7.cloudlinux will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-ruby for package: 1:ea-ruby27-2.7.2-6.el7.cloudlinux.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-mod_passenger.x86_64 1:6.0.6-6.el7.cloudlinux.4 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-rubygem-passenger(x86-64) = 1:6.0.6-6.el7.cloudlinux.4 for package: 1:ea-ruby27-mod_passenger-6.0.6-6.el7.cloudlinux.4.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-ruby-wrapper for package: 1:ea-ruby27-mod_passenger-6.0.6-6.el7.cloudlinux.4.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Running transaction check
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-ruby.x86_64 1:2.7.2-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-ruby-libs(x86-64) = 1:2.7.2-6.el7.cloudlinux.1 for package: 1:ea-ruby27-ruby-2.7.2-6.el7.cloudlinux.1.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-ruby(rubygems) >= 1:2.6.14.4 for package: 1:ea-ruby27-ruby-2.7.2-6.el7.cloudlinux.1.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-rubygem(bigdecimal) >= 1:2.0.0 for package: 1:ea-ruby27-ruby-2.7.2-6.el7.cloudlinux.1.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-rubygem(did_you_mean) >= 1:1.4.0 for package: 1:ea-ruby27-ruby-2.7.2-6.el7.cloudlinux.1.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-rubygem(openssl) >= 1:2.1.2 for package: 1:ea-ruby27-ruby-2.7.2-6.el7.cloudlinux.1.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-runtime >= 2.7.0 for package: 1:ea-ruby27-ruby-2.7.2-6.el7.cloudlinux.1.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-libuv for package: 1:ea-ruby27-ruby-2.7.2-6.el7.cloudlinux.1.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-ruby-wrapper.x86_64 1:6.0.6-6.el7.cloudlinux.4 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-rubygem-passenger.x86_64 1:6.0.6-6.el7.cloudlinux.4 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-rubygem(rack) for package: 1:ea-ruby27-rubygem-passenger-6.0.6-6.el7.cloudlinux.4.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Running transaction check
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-libuv.x86_64 3:1.41.0-1.el7.cloudlinux will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-ruby-libs.x86_64 1:2.7.2-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-rubygem-bigdecimal.x86_64 1:2.0.0-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-rubygem-did_you_mean.x86_64 1:1.4.0-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-rubygem-openssl.x86_64 1:2.1.2-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-rubygem-rack.noarch 1:2.2.3-1.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-rubygems.noarch 1:2.6.14.4-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-rubygem(rdoc) >= 1:6.2.1 for package: 1:ea-ruby27-rubygems-2.6.14.4-6.el7.cloudlinux.1.noarch
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-rubygem(io-console) >= 1:0.5.6 for package: 1:ea-ruby27-rubygems-2.6.14.4-6.el7.cloudlinux.1.noarch
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-rubygem(psych) >= 1:3.1.0 for package: 1:ea-ruby27-rubygems-2.6.14.4-6.el7.cloudlinux.1.noarch
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-runtime.x86_64 1:2.7.2-6.el7.cloudlinux will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-ruby-devel for package: 1:ea-ruby27-runtime-2.7.2-6.el7.cloudlinux.x86_64
[2021-06-02 19:39:23 +0300] info [xml-api] --> Running transaction check
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-ruby-devel.x86_64 1:2.7.2-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-rubygem-io-console.x86_64 1:0.5.6-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-rubygem-psych.x86_64 1:3.1.0-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-rubygem-rdoc.noarch 1:6.2.1-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-ruby(irb) = 1:1.2.6 for package: 1:ea-ruby27-rubygem-rdoc-6.2.1-6.el7.cloudlinux.1.noarch
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Dependency: ea-ruby27-rubygem(json) >= 1:2.3.0 for package: 1:ea-ruby27-rubygem-rdoc-6.2.1-6.el7.cloudlinux.1.noarch
[2021-06-02 19:39:23 +0300] info [xml-api] --> Running transaction check
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-ruby-irb.noarch 1:1.2.6-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] ---> Package ea-ruby27-rubygem-json.x86_64 1:2.3.0-6.el7.cloudlinux.1 will be installed
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Conflict: 2:ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64 conflicts mod_security
[2021-06-02 19:39:23 +0300] info [xml-api] --> Processing Conflict: 1:ea-modsec30-3.0.4-6.el7.cloudlinux.x86_64 conflicts ea-apache24-mod_security2
[2021-06-02 19:39:23 +0300] info [xml-api] --> Finished Dependency Resolution
<span class='text-danger'>[2021-06-02 19:39:23 +0300] info [xml-api] Error: ea-modsec30 conflicts with 2:ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64</span>
<span class='text-danger'>[2021-06-02 19:39:23 +0300] info [xml-api] Error: ea-apache24-mod_security2 conflicts with 1:ea-modsec30-3.0.4-6.el7.cloudlinux.x86_64</span>
[2021-06-02 19:39:23 +0300] info [xml-api] Leaving Shell

Error

<span class='text-danger'>Error: ea-modsec30 conflicts with 2:ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64</span>
<span class='text-danger'>Error: ea-apache24-mod_security2 conflicts with 1:ea-modsec30-3.0.4-6.el7.cloudlinux.x86_64</span>
The entire output was logged to: /usr/local/cpanel/logs/packman/errors/2021-06-02_19:39:23-1

Completed the installation process for the NGINX package.

---

Somewhere there is a conflict, as far as I understand it with CloudLinux, but here's what exactly... :)
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,148
784
313
cPanel Access Level
Root Administrator
That conflict wouldn't be related to Nginx, but there are two different ModSecurity packages on the machine that are causing issues. The 3.0 version of ModSecurity is still experimental, so I'd recommend removing that unless you are actively using the features it provides.
 

AlIur

Member
May 8, 2021
6
0
1
Moscow
cPanel Access Level
Root Administrator
That conflict wouldn't be related to Nginx, but there are two different ModSecurity packages on the machine that are causing issues. The 3.0 version of ModSecurity is still experimental, so I'd recommend removing that unless you are actively using the features it provides.
Please tell me if you have a link to instructions on how to remove it? Because I understand that it is not so easy to remove it)