The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nightly backups not working

Discussion in 'General Discussion' started by Chris Blount, Jun 9, 2005.

  1. Chris Blount

    Chris Blount Member

    Joined:
    Jan 30, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I have kind of a weird problem. I had the full backup routine running every night. It is enabled in WHM. For some reason back on May 21st, the nightly backup routine stopped working. I didn't change anything. The nightly log shows that the backup is not enabled but if you look in WHM, it is enabled.

    I contacted my ISP and they suggested going into the tweak settings and change the "The load average above the number of cpus at which logs file processing should be suspended" setting to 5 or above. I changed it to 8 and still no joy.

    If I run /scripts/cpbackup, it works perfectly.

    Any ideas? My ISP also suggested that I change to incremental backups which I haven't tried by I seriously think it is not a load problem.

    Thanks for the help.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Hi Chris,

    That is odd. Just to check what are the contents of your /etc/cpbackup.conf file?

    Here's mine for a nromal daily/weekly/monthly full backup cycle:

    Code:
    BACKUPACCTS yes
    BACKUPDAYS 0,1,2,3,4,5,6
    BACKUPDIR /backup
    BACKUPENABLE yes
    BACKUPFILES yes
    BACKUPFTPDIR 
    BACKUPFTPHOST 
    BACKUPFTPPASS 
    BACKUPFTPPASSIVE no
    BACKUPFTPUSER 
    BACKUPINC no
    BACKUPINT daily
    BACKUPLOGS no
    BACKUPMOUNT no
    BACKUPRETDAILY 1
    BACKUPRETMONTHLY 1
    BACKUPRETWEEKLY 1
    BACKUPTYPE normal
    DIEIFNOTMOUNTED no
    MYSQLBACKUP both
    BACKUPCHECK yes
    BACKUP2 yes
    
     
  3. Chris Blount

    Chris Blount Member

    Joined:
    Jan 30, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Here is the contents of my file:

    BACKUPACCTS yes
    BACKUPDAYS 0,1,2,3,4,5,6
    BACKUPDIR /backup
    BACKUPENABLE yes
    BACKUPFILES yes
    BACKUPFTPDIR
    BACKUPFTPHOST
    BACKUPFTPPASS
    BACKUPFTPPASSIVE no
    BACKUPFTPUSER
    BACKUPINC no
    BACKUPINT daily
    BACKUPLOGS yes
    BACKUPMOUNT no
    BACKUPRETDAILY 1
    BACKUPRETMONTHLY 1
    BACKUPRETWEEKLY 1
    BACKUPTYPE normal
    DIEIFNOTMOUNTED no
    MYSQLBACKUP accounts
    BACKUPCHECK yes
    BACKUP2 yes
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    All looks OK. Do you actually get a nighly email saying exactly "Backup Not Enabled"?

    Other obvious checks:

    1. There is sufficient free space on the partition that contains /backup

    2. Check /etc/fstab and make sure that something else hasn't been assigned /backup by mistake (e.g. a servers CD-ROM drive)

    3. There's actually a root cron job in the root crontab for /scripts/cpbackup:

    crontab -l

    If all else fails, good old update might help:

    /scripts/upcp --force
    /scripts/updatenow


    If even that doesn't help and no-one else comes up with a suggestion you may well have to log a support ticket with cPanel.
     
Loading...

Share This Page