The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No access logs saved

Discussion in 'General Discussion' started by InteractM, Jul 1, 2016.

Tags:
  1. InteractM

    InteractM Well-Known Member

    Joined:
    Apr 2, 2013
    Messages:
    133
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I have no idea what is going on but Apache 2.4 is not saving hosted cPanel accounts logs. Most of them have only one record from a day when particular account was created.

    Any idea what is going on?

    PS.
    It looks like it must be related to NGNIXcp from nginxcp.com and enabling mod_remoteIP


    Thanks
     
    #1 InteractM, Jul 1, 2016
    Last edited: Jul 1, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    It's possible you are noticing a change in the LogLevel configuration in Apache 2.4. You can view the "LogLevel" value in your Apache configuration file with a command such as:

    Code:
    grep -i LogLevel /usr/local/apache/conf/httpd.conf
    You can change the LogLevel to 'info' instead of 'warn' in the httpd.conf and then restart Apache to see if this addresses the issue. If so, or if you want to maintain this change, you can preserve the changes by following the steps listed in the following document:

    https://documentation.cpanel.net/display/EA/Advanced+Apache+Configuration

    Administrators can configure the "LogLevel" parameter via "WHM >> Service Configuration >> Apache Configuration >> Global Configuration" in cPanel 58.

    Thank you.
     
  3. InteractM

    InteractM Well-Known Member

    Joined:
    Apr 2, 2013
    Messages:
    133
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I have changed LogLevel to 'info' but still logs were not saved to particular domlog. It looks like NGNIXcp has to changed something as I have disabled it and logs came to be written back and enabled it back then it stopped to log.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. InteractM

    InteractM Well-Known Member

    Joined:
    Apr 2, 2013
    Messages:
    133
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    OK. I have got logs back by following those steps:

    1. Enable Piped Apache Logs - WHM »Service Configuration »Apache Configuration »Piped Log Configuration. Check the box to enable, and save
    2. Rebuild Vhosts - This is from within the Nginx configuration, not apache.
    3. Restart Nginx - Self explanatory
    4. Restart Apache
    Now I need to get real IP via mod_remoteIP and directions from provided first link

    Thanks!
     
  6. InteractM

    InteractM Well-Known Member

    Joined:
    Apr 2, 2013
    Messages:
    133
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    No clue why but logs are no longer mirrored to /home/{domain}/access-logs
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    It's possible Nginx installer changed the default logging format in the Apache configuration. You could check with the support team for the Nginx installer you are using to see if this is by design.

    Thank you.
     
Loading...

Share This Page